HERE2 via CAN identified but Pixhawk not using GPS

Hi everyone!
My Pixhawk on the Mini Carrier Board is connected via DroneCAN to the Pixhawk running Copter 4.3 However, while inspecting the CAN traffic, I can see the GPS data, the Pixhawk isn’t accepting it.

The Pixhawk can and outputs the messages from the Here GPS through SLCAN and even outputs the same messages when I check the autopilot through the UAVCAN GUI, but (I assume), that Ardupilot doesn’t like the data.
As another idea, is there any way to directly check the GPS position, the HDOP string or something so I can verify the actual data from the GPS?



Check GPSTYPE (or GPSTYPE2) parameter.

…I changed and (and just checked it) to 9 which is DroneCAN.
Just rewrote parameter to drone and still no change; any other suggestions?

Did you re-start the FC?

Yeah. Done it a few times now

How many GPS?
GPS is address 1?

I’ve got one GPS right now.

Do you mean the CAN Node ID? I’ve set that to 1 now. I’ve tried changing it multiple times but that didn’t change anything…

Check this:

Maybe it solves your issue

Thanks for your help so far…
I’ve gone through that guide a multiple times with different Copter (rover and plane too) versions to maybe elicit some sort of common trend which could be causing the issue, but I can’t find it.
I also know it isn’t some hardware fault because the Pixhawk is picking us the CAN transmissions perfectly fine. The GPS works perfectly fine through my Zubax Babel too.

1 Like