Servers by jDrones

Here2 & Here+ Compass Problems [SOLVED]

Solution - The Calibration process is disabled while the board is armed!
If you are using a watertight box for Rover / Boat projects where there is no external switch to arm/disarm you would have selected BRD_SAFETYENABLE to ‘0’ in order to disable it, THIS MUST BE CHANGED BACK TO ‘1’ to enable it just for the calibration process.

After reading this documentation many times over, I still cannot get my compass on my HERE compasses right. - https://ardupilot.org/copter/docs/common-compass-setup-advanced.html

I am using the Pixhawk2.1 Black Cube Rover 4.0 and have tried I2C and CAN in the Here2 with very little difference.The strange thing is that I can’t seem to calibrate the compass How I used to before the latest update of Mission Planner using the Onboard Mag Calibration.

The only compass calibration that seems available to me is the Quick Config Auto Declination.

Another strange thing is that I can’t seem to do the very basic ‘Access Calibration’ any longer on the latest Mission Planner.

I also keep getting the ‘Bad AHRS’ error

HOWEVER - The Pixhawk4 with Neo M8N Compass and Rover 3.5 is working just fine!

What am I doing wrong with the HERE?

First off is the Here2

Next is the Here+

Finally the Pixhawk4 & Neo M8N Compass on Rover 3.5

What’s really interesting here is how accurate the Neo-M8N GPS is when you look at the declination for my current location.

Declination -

West Heading on M8N -

This was my test base with ZERO magnetic interference -

HERE -
here

M8N -

Problem solved by Thomas Vanhees.

Great, that you and Thomas figured this out. I was actually not aware of this problem but I’ve raised an enhancement request to improve the warning if accelerometer or compass calibration cannot be started because the vehicle is armed. https://github.com/ArduPilot/ardupilot/issues/13663

P.S. if you’re looking for me, feel free to tag me in the discussion (by typing “@rmackay9”) or even better raise the issue in the Rover-4.0 or Copter-4.0 category. Thanks!

1 Like
Servers by jDrones