HERE+RTK on Rover 3m Boat

Did you try Compass Learn?
Yes, I use HERE+

Yes, tried it. However, we still have compass issues. I have tried to onlu use the GPS (Here +) for navigation and heading. Still it seems like the navigation is performed by the pixhawk cube and the heading is by the gps. When I move the gps, the arrow on the map is not turning. When I move the cube, the arrow on the map is moving. I want the arrow to move when I am moving the GPS. Is that possible?

Try only using external primary compass 1.

Hello John

I added some photos of the last trip we had with the boat.

What is the distance between those waypoints?
You have some sort of steering lag going on there i.e the actual steering action is taking too long.

The distance is between 10-20 meters. The lag is an issue. At that time we were 2 persons onboard so the total weight of the vessel was 350 kg. I suspect that the vessel is to heavy and therefore to slow to stop before any waypoints. I need to train it to understand that it needs to slow down before any waypoints. The waypoint overshoot was also set to zero, so it really struggled after it hit spot on the waypoint (it curved alot).

Another thought. I have a GNSS (, is it possible to connect this to the autopilot somehow? Perhaps through a laptop? I would be perfect for our purpose to have an external GNSS and an external compass (separate units) on the vessel.

Ok, wow, that is super tight, my craft turning radius is 13m so I could NEVER do that course.

This has always been a problem with Rover as the design code is for little cars and boats that can turn on a ticky, where our craft are like big oil tankers by comparison.

Your problem is not compass or GPS Iā€™m 90% sure of it.

The problem is momentum.