Help with tuning / Log analysis - large quad

I’m trying to figure out how to get some sort of stable flight.

from the basic tuning on this quad (4x 18 inch props, 320KV motor) it was going haywire - really all over the place.

one of the biggest issues is, in stabilize it’s just about able to stay in the air… but in althold or loiter it does this crazy vertical jumping up and down…

Please help me understand what to change?

In previous experiences someone has first gotten my quad flying and then i simply autotuned it further.

This time i’m doing it from scratch - the problem is while i have watched a bunch of tutorials for FPV tuning - this is a large quad - and i am pretty stuck on what to do to get this flying stably enough that i can do an autotune.

Motor-Motor centre diameter is approximately 750mm,
Autopilot - Cube orange + Here3
Take off weight = 4kg,
Battery = 6S10k LiPo 30C
Motor = MAD 5015 IPE kV320
ESC = hobbywing platinum 60A v4
Props = 18 inch 5.4
Copter 4.3.7

Had a quick look and the first thing I’ve noticed are vibrations.
Did you mount FC on vibration dampers or soft foam pads?

Did you follow basic tuning instructions?

Such size drones require more detailed setup prior to flying. - see:

Once that is successful you can move to notch filtering and auto-tune.

1 Like

I looked at your 16.bin file and I think you might have high vibrations.
You may need to use an additional shock-absorbing platform.
If you are already using a shock-absorbing platform, then you need to optimize it.

1 Like

Ah yes,tuning videos… You would do better reading the Arducopter Tuning docs.
Which of these 5 logs is a simple hover with some pitch, roll and Yaw? If none produce one. That said this ratio of P&I will likely not work:
Nor this ratio:

I would suggest setting these back to default. Set the ATC_RAT_PIT/RLL_IMAX back to default.
Set the Initial Tune Parameters as per the guide and set these:

And then make a simple hover flight. Or you could start over from default which could be a better idea if there are other parameters you changed I didn’t notice.

The vibe levels are very high but so is the output oscillation. The later has to be fixed 1st to know what you are working with. And the Notch filter has to be configured before real tuning commences. You are several step away from running an Auto Tune (and set aggression back to default also).

1 Like

ok - so made some changes - i got a solid 20-30 minutes of flight. (with a shaky drone… felt like 5hrs).

Uploaded fresh logs. - the last 2 (log 21 and 22 linked here: LINK DRIVE - i tried to do an autotune and couldn’t understand if it was actually doing any tuning? not sure why… i usually see it do the tuning twitch… here it wasn’t really… perhaps because it was just too shaky?

I did assume vibrations to be an issue - would love confirmation on that?

I changed a few things. reduced gyro and accel filters down not as low as suggested here. (saw this after my flights)…

Would love thoughts on the next step.

Currently what’s most concerning to me is the unstable altitude gains mid flight… i have read of very high vibrations, messing so much with the FC that you get a flyaway - now clearly… we aren’t there… as it was stable enough for me to lower it, but it was pretty noticeably flying up in althold mode.

with even minimal winds and even just with forward or sideways flight and especially with diagonal flight it seemed really wobbly…
I was happy to see it clearly had enough power to quickly stabilize itself… so i’m hopefull a good tune will really fly well - but right now - i struggle to understand - whats going on?
is my P too low/high? I too low? or D too low?

I reduced MOT_THST_EXPO to .6 and MOT_THST_HOVER to .2
Gyro filter reduced to 18 accel filter to 15.

I hadn’t adjusted this - but it seems i should have done the below to 50% of that accel filter? is that accurate?


One note - in the basic tuning on mission planner - it cuts off a bunch of initial parameters for frame size of 24 inch and above.

One more question - i was going to try potentially do some manual tuning. I’ve watched some videos on adjusting the PIDs but for FPV copters… in mission planner - the top row shows the P and accel MA.
Does anyone have any info or places they could point me to understand what these two settings are? basically it seems like P has 3 boxes that correlate to it - in my case:
for Stabilize roll
P = 11.250
ACCEL MA 25300
Rate roll box below:
P 0.0639
And so on… and then also for pitch and yaw.

Would appreciate if someone could shed some light there?
current PIDs

Auto Tune did not run because the tune is terrible. You will see the “failure to level” error messages in your last log. The outputs are oscillating wildly. You didn’t follow the Initial Tune steps in Mission Planner (Mandatory Hardware), for a 18" craft on 6S. It is pre-mature to run Auto Tune, it is not a fix all.
I’ll suggest again you reset all to default and start over. The PID’s you have now will not work. The D term is probably too high and the I term too high relative to P (set these equal).

The only parameters change you made that is in the right ballpark are these:

The vibe levels are way to high with 1000’s of clipping events. So you may as well address that before going further.

Are the FPV tuning videos you are watching targeted to Arducopter?

1 Like

Thank you @dkemxr i’m going to definitely implement those changes and see if it gets me stable.

I took over this setup in the middle - so i was not actually 100% sure what was and wasn’t done.
As per your suggestions I set as much of the default PIDs back to default.

Also swapped out the flight controller which was on ONLY antivibtration foam pads - and added an additional layer of rubber grommets for vibration isolation - which on a similar build i used to dampen vibrations drastically.

Hopefully with a clean start and lower vibrations - i’ll get some usable data to move forward.

You may want to use the Reset To Default button on the Full Parameter screen to reset all parameters if someone else changed them from default.

1 Like

Uploaded some new logs here:

so it’s a bit confusing… i had set everything basically to default.
i flew first in my garden - first in stabilize then in alt hold and got a very clean 30 second hover.
in order to keep it from drifting - i did minimal pitch and roll adjustments and maybe a touch of yaw.

Landed - went to the field for an autotune… and of course… problems.

No 1. - i didn’t save a screenshot of the exact PIDS. so im not 100% certain if everything was default or if i may have missed one or two items.
no2. the autotune i forgot was set to tune just yaw… it sent the drone into a circular craze… and i had to bring it down… thankfully very soft landing… but i then disarmed - and i think… the yaw from the autotune got saved… i wasn’t able to get it flying again - so back home now.

I think the vibrations are generally way better than they were.
the question is - whats screwed up? how to fix it?

Several items; you didn’t follow the instruction to reset to default and even if you did you didn’t set the Initial Tune parameters for that craft. You are making no progress.

Why? It looks like you made some random changes to the PID’s, of course it’s going to fail.

I could just repeat what I have already posted. And after you have actually reset all to default, and actually set the Initial Tune Parameters, make one (1) hover flight in AltHold and post one (1) log. No one is going to go thru the 9 logs you posted looking for something useful to comment on.

1 Like

Alright - this time everything was default to the tune params for a 30inch quad frame.

Here is the results:

logs attached - and video as well.

The drone takes off smooth - and can handle the smallest movement staying level but as soon as a bigger movement happens (in alt-hold) - the drone enters a crazy spin.

Log 37 is a small hover in stabilize.
Log 38 is a hover in stabilize, a hover in althold and an input left and right… which resulted in a lucky safe landing maneuver.


EDIT: uploaded another log - just in stabilize… holding a hover just in case the althold log doesnt accomplish the simple hover log starting point.
The default PIDs get it taking off pretty level - but it’s unflyable with almost anything besides the lightest input… it can’t seem to recover fast?
Also @dkemxr Thanks for the help - i do appreciate it!

It’s not based on frame size. Your 1st post said 18" props and 6S power. Is that right? That’s what’s entered in the Initial Tune Parameters screen. You will have to get this right and do another hover flight in Althold. One take-off and one landing , multiple attempts in one log is not helpful
Vibe levels are better but still high and still clipping events. Are the props balanced?
May as well enable this now, you will get to it soon enough:
BTW-Auto Tune is NOT run before the notch filter is configured. But understand it’s not a fix for high mechanical vibration.

1 Like

That explains a lot!
I thought “airscrew” size… referred to the wheelbase…

ok 2 stabilize logs. log 40 i flew up a bit to fast and felt a loss of control - despite it actually flying ok - so i disarmed cracking a leg support.

next log 41 - uploaded a log with just a stabilize hop. slightly fast landing so resulted in the drone tipping. no damage done - but the end will show a large vibration i’m sure.

i couldn’t tell if this resolved the pitch and roll. i didn’t see any pitch roll issues - but didn’t push it much at all…
will be interesting to know your thoughts.

I did not see the notch filter before testing. ive changed that now before flying again tomorrow.

are my vibration levels manageable? Z seems high? (i’ve tried to stick down any loose cables and have a rubber isolation pad now holding the flight controller - does it seem good enough?
and what next to get this tuned?
my goal here is not for a fast drone - but a super stable - even somewhat slow drone that i can send to a few waypoints and bring home. reliability over speed 100%.
My goal was get an autotune done - and then be ready for simple waypoint missions in auto.

These flight are so short and almost useless. This is why I have said several times Hover in AltHold. For about 1 minute and get it off the ground more than a few meters. And set these:

At least you have the Initial Tune Parameters set correctly now. You are close to a baseline to begin tuning. Not running Auto Tune, basic tuning for stable flight.
Are you sure of these values from Setting the Motor Ranges? Setting Motor Ranges

1 Like

New flights in alt hold.

I’ve been experiencing consistent tuning issues with my quadcopter during Althold flights. I’ve observed a repeating pattern: initial stable flight gradually devolves into wobbling, ending with a soft crash or unstable landing.

The logs Log 43 and video ( from this recent flight illustrate this problem. The copter hovers for about a minute before the oscillations and unstable landing occur.

I’m uncertain whether these oscillations are due to high or low P gains. From the tuning videos for FPV it suggests that high P gains usually cause rapid back-and-forth oscillations. However, given the weight of my copter, I’m wondering if these slower wobbles could actually indicate excessively high P gains for a heavier drone.

Am I misinterpreting the effects of P gains on a heavier quadcopter? Any insight would be greatly appreciated!

What next?

Yes - manually set these after a bench test.

Make these changes:
ATC_RAT_PIT_I,0.100 (same for Roll)
ATC_RAT_PIT_P,0.100 )same for Roll)

Then try again. If the flight is Stable set this:

Are your props balanced?

1 Like

ok - so this flew much better - especially in the beginning.
At first, i could steer left and right - with minimal issues though clearly not snappy and crisp - a slight wobble.

Then as in previous times, it went into a death oscillation wobble… luckily very low and on grass.

Log 45 for reference. I did not change ATC_THR_MIX_MAN to 0.5 yet.

they were - i have been scuffing them up a little with each crash. was planning to swap out these test props once the drone is flying a bit more stable to a 2nd pair of the same props.

I said to update the Rate Roll P&I the same as Pitch in the last post, they are still at default. And I don’t know how you arrived at this, it’s 10X higher than it should be:
Set this to default 0.018

You actually balanced the props with a balancer?

Ok - this worked a lot better - i was confident enough to try loiter - which was fine - with small inputs. Actually held it’s postion very well.

That said - in alt hold and even in loiter there is a certain level of shakiness, and wobble.

I know i’m not there yet… but with the stability i was seeing i took a leap and tried an autotune - of course it failed - miserably - but spectacularly and i mean wow… it didn’t crash - and it restored itself FULLY!! enabling me to do a nice slow landing.

CRAZY video is the 3rd flight in the video.
I did an alt hold - which i didn’t catch on video - but it’s in the log.
same log then has a flight i accidentally did in stabilize thinking it was althold… woops - i landed it… but it tipped over from the forward movement - no harm done.
then i have a loiter flight - super smooth.
then i have an althold and attempt at autotune.


Any idea how to fix the crazy wobble? it seems to have mainly only affected two motors?

Vibrations are still a bit high but dont appear to be causing issues (yet). So I’m a bit hesitant to ask you to set this yet:
If you were good with Stabilise mode and ready to flick that mode switch it would be fine to set that parameter now.
So if there’s anything you can do to improve vibrations, like securing wiring, time spent will be well worth it for tuning and future flight time and enjoyment.
Send a photo of the flight controller and wiring, and any other area that might be the source of vibrations.

Set these to help GPS, increase logging and settle down the hover/altitude issues.


Set these to adjust the Harmonic Notch filter a bit. It wasnt bad but was missing the base frequency at about 44 Hz

INS_HNTCH_FREQ,46 <- yes 46 not 44

This should be the result:

For the PIDs I’d like to see another test flight in AltHold with the increased logging before we go changing more. Just do a few gentle pitch and roll movements or what ever is safe.
Let’s see that log file and we should be able to do more with that instability.