Servers by jDrones

Help with skidteer mode

Hi there,

I’m setting up my new rover and I’m using the Dagu Wild Thumper 4WD
https://www.pololu.com/product/1567

and as a motor controller: RoboClaw 2x15A Motor Controller (V5E)

https://www.pololu.com/product/3285

I set up with my Taranis plus and receiver X8R with the following configuration:
Left Stick Throttle, channel 3
Right Stick Direction Channel2

If I did not connect to the Pixhawk cube, the rover works perfectly.

But when I connect to Pixhawk with the following config:


image
The Rover did not works
If I make a test Motor
image
Only works right wheels,

If I press test motor C : The right wheels rotate in forwarding mode, the left did not work
If I press test motor D : The right wheels rotate in forwarding mode, the left did not work

Any idea what I’m doing wrong?

Thanks all

Eduard

I just went through this.

ArduRover seems so modular and abstracted that you’d think that you could put your input channels anywhere and you could get skid steer to work.

Not so. The assigning of Servos 1&3 to 73 and 74 throttle left and right outputs initiates skid steer mode, but then if your throttle and steering (ahem, throttle and roll) aren’t on 3 and 1 RC inputs, it isn’t going to work.

I was doing my own cowboy thing with input channels and was having a hard time as well.

actually you could assign servos 2 and 3 to 73 and 74 if you wanted. I think using RCMAP you can set the inputs up differently.

finally it works, I had to remap the transmitter , and align all the devices to use the same channels.

Thank’s all guys

@direktor,

Just to re-iterate a bit on what @David_Boulanger has said. AP is definitely abstracted enough that inputs and outputs are completely separate. Only in very old versions (Rover-3.1 perhaps?) do they need to be the same.

The Motor Test page by passes the input side of things so using this page is the best way to figure out if the outputs are mapped correctly (i.e. SERVOx_FUNCTION params). No matter how the inputs are changed the results of the MotorTest should not.

I guess @ecabanas has worked it out now but I suspect there was (at least) an issue with either the SERVOx_FUNCTION values or an issue with the RoboClaw motor driver setup.

Hi,

I have a RoboClaw 2x60A Motor Controller wiring to a Pixhaw to control two trolling motors.
I only have got to work ok with analog signal setup on BasicMicro Motion Studio and also I need to deselect the mixing option. I thought it must be setup as RC signal but it doesn’t work at all.
On the other hand, I have a couple of extrange things…I must to set the MOT_SAFE_DISARM = 0 (0:PWM enabled while disarmed 1:PWM disabled while disarmed) because if I set to “1” the motors run at high speed when disarm the system…
The motors Works ok (tank style) but I need to select PILOT_STEER_TYPE = 0 (0:Default 1:Two Paddles Input 2:Direction reversed when backing up 3:Direction unchanged when backing up) instead of “1” as seems the correct option.
Further, when I switch off and on it seems like the Roboclaw loss the saved setup or something like that because I need to connect (usb connection to PC) and select/deselect the mixing parameter and it Works fine again…I don’t understant what happend…
I have Rover 4.0.0 and the motors are wiring to servo1 and 3 with 73 and 74 servox_function
The idea is to control a boat in Skid Steering mode. the motors are used to turn the boat, aditionally I have a big motor managed by a 3 phases speed frecuency regulator connect to servo2 output setup as 70 (Throttlle) by a PWM converter and it Works fine when I control the system with the Logiteck joystic. No test in auto mode yet.

Any ideas??
params_08062020.param (16.8 KB)

Servers by jDrones