Help with Pixhawk 4 and Crossfire

I recently bought a Crossfire Micro Tx v2 for my X9 Lite. I also got the nano diversity v2 rx (the focus of my issues). The TX and rx are bound, updated, etc. via TBS Agent X already and the X9 Lite has been modded with nightlies and is set to crsf.

My issue, is I CAN NOT get RC inputs into my Pixhawk 4. I tried CRSF first, but ardupilot doesn’t really support it yet and the workarounds didn’t work. Next, I tried following painless360 on setting it up via mavlink and still no RC inputs.

I’ve tried setting BRD_ALT_CONFIG = 1, serial4_protocol = 1, 2, 23, 28 (serial 4 on pix4 is telem 2 port; option 23 is rc in, option 28 is crossfire), and a couple other things I can’t remember…but still nothing.

Any help ideas?

Are you running 4.1?

4.0.7 what does 4.1 change? My mission planner only has up to 4.0.7

Edit: where do you see that copter 4.1 is available? I just downloaded the latest mission planner and it only has up to 4.0.7.

Press Ctrl>Q from the firmware install menu to load the Master/Dev versions.

4.1 (still in alpha) supports CRSF properly