Help with loss of collective movement when armed

Please can somebody be kind enough to have a look through my .param file.
I have full cyclic and collective movement when disarmed, when armed I lose collective movement.
When I spool up motors still no collective but cyclic moves correctly.

I’m on v4.4.4
Matek 405WING V2
RC is crossfire, using standard channels for signals and servo outputs
I can provide more information if required but I suspect I’m missing something simple that somebody cleverer than I can find :smile:

240312_TB40.param (19.4 KB)


Please post a log. You can enable logging while it is disarmed by setting LOG_DISARMED to 1. Power up and demonstrate that collective works disarmed. Then arm the aircraft and before starting the motor move the collective. If you want to provide more data then start the motor and move the collective.

I’m assuming that you are doing this in stabilize mode?

Hi Bill Thanks for your quick reply.
Log file attached, sequence to create this was:-

  • power-up, wait for initialistion
  • collective down-up-down
  • armed
  • collective down-up-down
  • motor interlock high, motor spools up
  • collective down-up-down
  • motor interlock low, motor spools down
  • collective down-up-down
  • disarmed
  • collective down-up-down
  • power off

Stabilze mode set all the time,

Look forward to hearing back from you
Thank You
00000002.BIN (876 KB)

Hi Steve,
I just looked at your log and I think, I may have found your problem. In the RCIN signals I can only see two up-down cycles of channel three, which is collective pitch. When you’re in the armed state, CH3 isn’t moving at all. Even the jitter stopped. So, it seems your collective movement isn’t even entering the ardupilot flight controller. I can see, that you’re using CH7 as arming switch (RC7_OPTION,153). My first guess would be that there is a setting in your transmitter, which freezes CH3 as soon as you flip the arming switch. So at first have a look at the output signals of your transmitter. Maybe it is as easy as that…? If not, I’m sure that Bill can provide a way more qualified answer than me.

1 Like

Hi Felix
Excellent detective work :smile:
For some reason I can’t explain my TX CH3 input parameters (I use Open-TX) were looking at switch F which is my ‘arming’ switch.
Deleting that has solved the problem :clap:

Thank you very much indeed for your help with this.
Thanks also to Bill @bnsgeyer for his interest

1 Like

Hi Steve!
That’s great! I’m glad, that this solved your problem. Have fun flying! :slight_smile: :helicopter:

1 Like