Help with autotune. 3.3rc10 / upgraded frame


Last week I upgraded my hexa frame with new motors, blades and battery to enhance flight time, together with arducopter from 3.3rc8 to rc10;

Old Setup:
Tarot hexa 680 pro
multistar 2216-800Kv motors with 12x4.5 carbon blades
15.2ah 4s lipo ( 10 + 5.2ah )
3.8Kg full weight

New Setup
Quanum mt 3508-700Kv with 13x5.5 carbon blades
20Ah 4s multistar lipo ( 10+10 )
4.1K full weight

Due to the new setup I need to reconfigure the PIDs. For that, my first attempt was to call autotune, taking off with the old PID letting the routine do its job.

The resulting PIDs seems to be very responsive, however bouncing a little bit on the roll axis. Since the hexa now is a little overpowered ( hovering with 420 throttle ), I ended up decreasing 10% the Stabilize P , Rate P/I gains to solve it.

The day that I run autotune was a little bit windy ( 5/10 km/h gusts ), so I’ve decided to try it again. Now the roll stabilize P has halved its value and even so the copter was still bouncing a little bit on the roll axis.

So I decided to give another try, but this time resetting pixhawk to fac. default values.

Comparing the results i couldn’t find an explanation for the noticeable difference among the values. I got the very same wobble on the roll axis. This wobble only stops if I decrease the values by 10% .

What has called my attention was the difference between roll and pitch values between autotune sessions. Nothing was changed on the frame between the tests.

1st autotune:
Stabilize P : 13.775
Rate P/I: 0.2298
Rate D: 0.009265

Stabilize P : 8.247
Rate P/I: 0.20475
Rate D: 0.013966

2nd autotune:
Stabilize P : 5.4
Rate P/I: 0.234
Rate D: 0.0104

Stabilize P/ : 10.8
Rate P/I: :0.3114
Rate D: 0.144

3rd autotune ( after resetting to factory default ) :
Stabilize P : 13.71
Rate P/I: 0.2683
Rate D: 0.0111

Stabilize P/ : 11.28
Rate P/I: :0.2958
Rate D: 0.109

Could anyone clarify to me if it is needed to reset arducopter to the default PIDs prior to run autotune?

Does anyone have an idea of why the values for roll axis are so different between autotune sessions , specially stabilize P ?

Which values should I decrease to avoid wobble ? Only stabilize p or all the values like I did?

Here are the logs for the autotune sessions: … sp=sharing

It is important to say that the frame is well balanced, however the weight distribution is a little bit different on x and y axis.

I’m willing to help and test whatever needed.

Regards, Fernando

I hope they fix autotune before the final release. I ran it on my CX-20 after I upgraded it to Pixhawk and got worse garbage than you did. That worked really well on older versions. Maybe something in the code accidentally got messed up.


They might change something with the filters before next stable release. I managed to do the autotune again without almost no wind. After I have decreased by 10% the autotuned parameters below and, that by itself fixed the overshoot problem.


yeah, well I ran autotune for the first time on my carbon bumblebee 550 about 20 mins ago… and it was not what i expected. I was glad to land and disarm without saving t6he autotuned PID’s. It was terribly bouncy when stopping , almost unflyable! I dunno. its not what i expected!

With older firmware versions (when Autotune first came out) it worked very well. It seams like it got broken a few versions back.


Hi tabascoz,

Can you supply some pictures of your frame?


Yes, of course. I’ll take them at night.

Here they are… I’m currently flying with the rate parameters decreased by 20%. I’ve flown 6 times since then ( more than 1.5h ) and it looks great.

Looking forward to help and test… If you need anything else please let me know.

Hi Tabascoz,

This is what I get from your logs.

1st autotune:
Stabilize P : 6.0
Rate P/I: 0.26
Rate D: 0.0103
Accel : 70000 ish

Stabilize P : 10.8
Rate P/I: 0.345
Rate D: 0.0143
Accel : 73000 ish

2nd autotune:
Stabilize P : 8.2
Rate P/I: 0.229
Rate D: 0.000926
Accel : 79000 ish

Stabilize P/ : 10.8
Rate P/I: :0.204
Rate D: 0.0139
Accel : 54000 ish

3rd autotune ( after resetting to factory default ) :
Stabilize P : 13.71
Rate P/I: 0.2683
Rate D: 0.0111
Accel : 84000 ish

Stabilize P/ : 11.28
Rate P/I: :0.2958
Rate D: 0.109
Accel : 69000 ish

So I am not sure why your values in your post are so far out. Your second and third logs both look like they were reasonably solid autotunes. However, I do see a little kink in the rate step response that may be caused by your batteries moving. This also appears to be likely based on your photos of your quad. We also see this when gimbals are in place but your gimbal is pretty light compared to the rest of the frame so I think the batteries are the likely culprit.

So can you move the batteries at all under the frame?

Hello Leonard,

Thanks for looking at it. I got those values by reading the mission planner parameters after the autonune , on next flight. I could have mess up with them when transcribing my notes or it could have been something else. I’ll pay more attention to that to figure it out…

The batteries are pretty tight but they do have some play. The battery holder arms and the whole system deforms a little bit if I push them, but I need to apply some force for that. If I hold the frame and simulate the movements i cannot see any play. But , for sure, it could be the reason for the difference between AT runs among roll.

Could you point me how to read the AT values from the logs? I have tried to learn it but couldn’t find.

I’ll post below my latest autotune log and my current PID settings. What I have made was to decrease ( and round ) the values by same factor until I got rid of the bouncing.

I can move the batteries. Like they are now, the frame is well balanced on both axis. If i move them under the frame it will be a little unbalanced because of the gimbal. Should I try autotune again like that (little unbalanced ) or should I get rid of the gimbal and put batteries straight above, well centered?


Here is my latest autotune run. That day there were no wind at all. I ran the atune in two steps , firstly on roll/pitch and after on yaw. … jVMUTNkN0U
The file is Autotune_2015-09-13.tar.gz

I’m flying with Stablize R/P *-10% , Rate R/P * -20% and ATC_ACCEL_{P,R}_MAX *-10% . After that I’ve rounded the stabilize and rate values. The hex is flying very well right now.

What is your opinion regarding the corrections?

[attachment=0]Screenshot from 2015-10-03 17-44-02.png[/attachment]


Here is a flight with these parameters. My gimbal is shaking a little bit on roll axis when I fly with wind. I’m tracking down this problem… Except that, the fly looks solid. There were gusts of 40Km/h, almost unnoticeable.

Log: … jVMUTNkN0U
File: 2015-09-27 09-14-55.log.tar.gz

What do you think? Better avoid fixing what is working or there is room for improvement?

Hi Tabascoz,

I wouldn’t touch it from there!!!

I don’t think those roll vibrations are coming from the copter, I think that is the wind hitting your gimbal. I say this because I was watching your motors or landing gear when they happened and I couldn’t see the frame moving in a way that would cause those shakes. I also can see the gimbal does take out the fast movement of the frame when I see the frame moving.

It doesn’t take much flex to cause issues like this, but it may also simply be because you are tuning with a high value of Autotune_AGGR.

I would suggest that you save these PID settings and enjoy the copter. Then if you feel like it I would do another autotune with AUTOTUNE_AGGR set to 0.05 in perfect conditions. And see if that gives you nicer values right out of the gate.

To me things really look good so I would just enjoy it mate!!

There are two things about this that really put a smile on my face. First your yaw response is really crisp and assertive. (If you want to make it a little more gentle drop your ACCEL_YAW_MAX a little). The second thing is I love the fact you felt comfortable enough to go flying in 40km/h gusts and then get the quality of video you got there. I know that many people wouldn’t even consider flying in those conditions, especially using other systems. I know Arducopter will handle this because part of my control loop testing is in the worst conditions I can find but many people haven’t realised how well these machines can handle rough weather.


I’m very pleasant to hear your comments. I feel very very confident to fly with Ardupilot, because the quality of the code ( I’m studying it a lot), and 3dr pixhawk and GPS. You guys are great!

I have mainly changed the frame from quad to hex in order to be more confident regarding hardware failures, specially with the motors. But, as a side effect I’ve find out that the bird is way more stable than the quad in chaotic wind conditions; I mean chaotic because that day there were a cold front approaching. It is important to note that I have never heard anyone highlighting this characteristic.

Regarding the gimbal, I’ll try to raise their PIDs or motor power , hoping that it would be more resistant to the wind.

I’ll watch carefully the weather conditions to find another day like that ( last autotune) to test it with d 0.05. They are rare…

Since here where I live I have plenty of open space with rough weather, whenever you need me to test anything, I’d be very glad to help.