Servers by jDrones

Help with ardurover


(dottantgal) #1

Hi all,
i am new in this forum and i ve started my research on ardurover.
I wanna know if it s possible to apply the ardurover system on this type of RC car
rc-carsplus.com/electric-powered … r-rtr-1-8/
It has this type of receiver and ESC

I have also a pixhawk, a transmitter FS-TH9x and a receiver FRSKY D4R-II 4chan
I’ve followed the wiki and I’ve tried to upload the rover firmware, it seems to work on the pixhawk (i’ve tried to connect it to mission planner/qgroundcontrol and i can calibrate the RC transmitter), but when i try to connect the pixhawk ’ pwm output to the rover’ motor (throught the rover ESC) and steering servo nothing happen.
Anyone can help me?
thanks in advance


(Thomas J Coyle III) #2

@dottantgal,

I am using a Spektrum Remote Receiver (serial) and a DX7 transmitter with my Pixhawk.

In the MP Full Parameter List I have set up the following RCMAP

RCMAP_PITCH channel 3 (not used)

RCMAP_ROLL channel 1 (aileron) steering

RCMAP_ THRO channel 2 (elevator) throttle

RCMAP_YAW channel 4 (not used)

RCMAP channels 1 and 2 are used for steering (aileron joystick) and throttle (elevator joystick) respectively. Your steering servo will be hooked to the Pixhawk servo output channel 1 and the throttle to channel 2.

You will also need to set up the CH7_OPTION and the MODE_CH. I used channel 5 (gear switch) for the CH7_OPTION and channel 6 (flaps) for the MODE_CH.

Your Flight Modes should be from top to bottom: Auto, Auto, Learning, Learning, Manual, Manual.

How have you connected your R/C receiver to the Pixhawk? Are you using a PPM encoder and a parallel output R/C receiver?

Remember, you need to Arm the Pixhawk with the push button before it will provide any PWM output on its servo output channels.

The above should help you get going with a PPM encoder and parallel output receiver. Your transmitter must support at least 6 channels.

Regards,
TCIII ArduRover2 Developer


(dottantgal) #3

Thank you so much, i ll try it.
Just one question: what is the pixhawk “push button”? is it the reset or the button connected to the switch port of the board?
Thanks


(Thomas J Coyle III) #4

@dottantgal,
The arming switch is the switch that flashes red when disarmed and goes solid when the switch is pushed for 5 sec to arm the Pixhawk.
Regards,
TCIII ArduRover2 Developer


(dottantgal) #5

Ok, i ve done it.
Is it normal that i control the rover using just the right stick?
do i need to set any parameters on the mission planner to use 2 sticks?
thanks


(Thomas J Coyle III) #6

@dottantgal,
Here in the US we normally use Mode 2 R/C transmitters with the aileron/elevator joystick on the right and the throttle/rudder joystick on the left. The throttle joystick, unless it has been modified with a neutral point, will not provide reverse if used as the throttle joystick.
The aileron joystick provides steering and the elevator joystick provide forward and reverse throttle. You can use the left joystick for whatever you want to use it for as long as you assign the rudder and throttle channels to whatever output channels you want in the MP.
Regards,
TCIII ArduRover2 Developer


(dottantgal) #7

Hi, thank you, now i have throttle on the left stick and steering on the right stick, but i need to reverse the steering cause the rover turns left when i move the stick to the right.
is there a parameter to set?
i’ve tried with RC1_REV but nothing happens.
I also need to set the max throttle speed in auto/manual mode…is it possible?
I’ve found some parameters like THR_MAX or MIN but they don’t fix my issue.
Thank you


(dottantgal) #8

I’ve fixed the steering problem (i ve changed it on my transmitter), but i can’t handle the max throttle speed for the AUTO mode( i’ve just set an acceleration parameter so when i swithc to the auto mode it doesn’t start from the max speed).
Another thing: is there any way to set a deceleration param? i ve saw that the motors had an hard stop if i move the throttle stick to 0 and i don’t want to brake them.
Thanks in advance.


(AndWik) #9

Start problem:
If I power on and arm before GPS fix, the Rover starts and navigates.
If I wait and arm after GPS fix it does NOT start, or it does after a long time.
If I disarm my running rover and arm it again it will not start again.

And please:
Can’t the rover log as much as the APM Octo does. There is not much you can check in the logs compared to what you can check after flying.

Thanks
Anders
Sweden


(AndWik) #10

I tried the latest version today and uploaded the log.
Now it shows a huge amount of info as the APM Copter does. Thanks a lot!!!

Anders
Sweden


(gmorph) #11

@dottantgal - I’d suggest you read through all the parameters available to Rover:
rover.ardupilot.com/wiki/apmrover2-parameters/
Here you will find everything you need to set the speed of the rover and the deceleration configuration. Two good parameters to start with would be CRUISE_SPEED and BRAKING_PERCENT.

@AndWik - you probably should of started a new topic in the forum :slight_smile:
The logging is the same between vehicles when common libraries are used i.e. GPS. It would only be a small amount of vehicle specific logging that is different. If you find anything missing or required please let us know.
Rover doesn’t support arming like plane and copter - only the safety switch. I assume your setting auto mode (or having the rover start in that mode) and pressing the safety switch before GPS lock?
When you say it does not start ot starts after a long time - how long is a long time. If its less then 5 seconds its probably integrator windup because of your ESC which is optimised for high speed. A better ESC would help but not fully resolve this issue.
How are you disarming the running rover?

Thanks, Grant.


(Anders Knudby) #12

Hi, I am a newbie here. I have a Pixhawk2.1, and an FrSky Delta-8 receiver. I have not found anywhere that shows specifically how to connect the two, including what type of cable to use. Yeah, like I said, I’m a newbie. A photo would be nice, but detailed explanation would be very helpful too. Thanks for a great forum!