Help with APM1

I need a little help.
about 18 months ago i built a small quad with an apm1 and the blue sensor shield.

I have since then purchased an axn plane and would like to move the apm1 into it and see what happens.
I booted up an old pc that has the old mission planner on it, let it update to version 1.2.?? and connected, verified the board was still working etc and tried to get arduplane on it.

The old mission planner was giving me connection errors when trying to download arduplane, so i donwloaded mission planner 2.0,
connected the board to the pc, put the arduplane on it and ā€¦

now nothing works, I cant connect to the mission planner at all, I can upload other firmwares to it, I can even select old ones in the 1.2 mission planner and upload them , but now it wont connect, it either times out with an old firmware, or with the current firmware it gets stuck trying to download mag_dec.

My guess is that apm1 isnt compatible with the new firmware and that I have to put an older version on it, can anyone tell me what the latest old version is ? and how to best get it on the board ? I have spent hours trying to get an arduino sketch on the board that simply refuses to compile even after copying all libraries into the right folder, leaving arduplane in the sketches folder and downloading the latest arduino,

hopefully someone can help me before the apm goes flying through the window into the garden :slight_smile:

If your APM1 is a real APM1 and not an APM1.4 then it probably has an Atmega1280 processor which has half the memory of the AMP1.4 Atmega 2560 processor. I believe that the Atmega 1280 does not sufficient memory to hold the latest ArduPlane code and you will have to reduce some of the functions to get it to load on the Atmega 1280.

I had a look at this chip and its an atmega 2560.
Iguess the fact that arduino wont compile is down to my pc. But I cant work out why missiin planner apparently uploads ok and verifies with no error and then the board wont connect

Hi Moose,
The APM1 does still work as long as it a AVR-2560 based board. Get a magnifying glass out and look for the markings on the main CPU. If it says ā€œ2560ā€ it should work.
I have a APM1-2560 running APM:Plane 3.0.1 on my desk right now.
Cheers, Tridge

I had replied earlier but apparently it didnt post,
it is a 2560.
I cant work out why it wont connect, i have tried a hex file directly through the old mission panner option, tried old firmware in mission planner 1.2 and tried the latest in 2.0 but it wont connect after changing the firmware from what I was using 18 months ago.

Like i said, I cant get the code to compile in arduino , for some problem in windows, and the code in both versions of mission panner loads and verifies ok, but the board doesnt seem to do much when powered on after, during programming all the lights etc seem to be okay ,

upon power on the blue ppm light etc works, during connection i get some random blips on the rx light, but not much else,

And again, the board worked fine with the old firmware yesterday so I doubt its broken

That is quite strange. Iā€™d suggest you install this version of arduino:
(follow the instructions in the PDF carefully) and try to debug it
Cheers, Tridge

HI ,
I didnt go down the arduino route as after reading the pdf I didnt think I would have enough time to get it working,
Instead i spent an hour installing the old firmware through mission planner 1.x after several attempts the board sprang back to life, and started connecting both in mission planner 1.x and 2.x

I then installed the firmware from 2.x and it died again, so i put the old 2.65 on it and it came back to life, that cycle contiued for around another half hour, then I found a link to all the hex files, got 3.0.1 and used mission planner 1.x to instal it, and after around five mins thinking it was dead, i left it in a moment of despair, went for a drink and when i came back it was working,

seems that 3.0.1 takes a longer time to initialise than the older versions, but once done it seems to be working ok,

If anyone else reads this post, the three status lights dont really do much in 3.0.1 and so you may think its not working but it is,