Servers by jDrones

Help with airspeed sensor


(Lbarreiro) #1

Hi

I’m having trouble installing a airspeed sensor via I2C port on pixhawk cube with the last firmware.
I have one as show in ardupilot instructions for plane and followed all the steps without success.
I used for the ARSPD_PIN the value off 15 and 65, for the ARSPD_BUS the value 0, 1 and 3, and for the ARSP_TYPE chose all the sensor available.
I also check the connections, VCC, ground, SCL and SDA, it seems all okay.
Any ideas?
The mission planner don’t show any readings in all the combinations.

Thanks


(Paul) #2

Had these settings working well, but with a Pixracer and ArduPlane 3.8.4.


(Atico) #3

Maybe you can have the tubes inverted. To avoid it you can change:

ARSPD_TUBE_ORDER = 2


(Lbarreiro) #4

Thanks for the quick responses.

I have tried both without success, maybe a default sensor or I2C port malfunction?

Anyone with Piixhawk Cube?


(Nathan E) #5

What airspeed sensor are you using?


(Lbarreiro) #6


Airspeed Sensor Calibrating
(Lbarreiro) #7

Anyone please :slight_smile:


(Atico) #8

Check the pin on the I2C connector of the Cube.

ARSPD_TYPE = 1 >> 4525 airspeed
ARSPD_PIN = 65 >> Cube


(Lbarreiro) #9

Hi Aticof
Thank you very much!
It all works now, the strangest thing is that I have to reboot the Pixhawk for all start working.