Help tuning large, overpowered quad

I’m working on getting a large (10Kg w/o payload, 26" prop) quad up and running. I’ve got it flying decently, but there are a few issues remaining I’d like some help on.

Doing some “speed runs” yesterday, it often became very unstable when coming to a stop. It would recover and continue flying, but was definitely alarming. Reviewing the logs this seems to be happening when the throttle (CTUN->THO) hit its lower limit. I also notice some “surging” on the throttle output, even under mild maneouvering.

Repeating the same flight, but this time with an extra 5kg strapped on, all was well.

I would like to be able to fly this quad without ballast, are there some other settings that should be tweaked?

Logs below:
problem flight
https://drive.google.com/file/d/1WMuDoD1x3lZ_wTUAI2mCTA0BiFDFbqGo/view?usp=sharing
good flight (5kg payload)
https://drive.google.com/file/d/1mdVJTDlTRgFaXdJRtfdGIqsg7R8eM9DD/view?usp=sharing

1 Like

Logs have an access requirement.

Oops, please try now. I think I fixed it.

I would update to current Stable or Beta 1st. To deal with that Throttle oscillation set these:
PSC_ACCZ_I, (to 2X MOT_THST_HOVER)
PSC_ACCZ_P, (to MOT_THST_HOVER)

Your Z vibes are a bit high. I see you have the Dynamic Notch Filter set but this isn’t a valid parameter value for analyses INS_LOG_BAT_OPT,3 Either 0 for pre or 2 for post filter data. So maybe worth another look. It would be interesting to see your pre-configuration hover flight with it at 0.

Auto Tuned I suppose but I don’t think it did a great job. ATC_ACCEL_R_MAX is high and Rate P&I’s are low relative to Pitch. Perhaps set R_MAX equal to P_MAX and pick an average value (~.100) for rate P&I and give it a try. You also definitely want to set these:
MOT_BAT_VOLT_MAX
MOT_BAT_VOLT_MIN

Thanks. I’ll give that a try. I’ve been meaning to setup the notch filter as well, but haven’t got to it yet.

The discrepancy of roll vs pitch is not unexpected. This is an H frame with a much higher MOI for the pitch axis than the roll. I might try an autotune with the extra mass and see how that works out.

At one point I set MOT_SPIN_ARM to 0.07 (as low as the motors can handle) and MOT_SPIN_MIN to 0.09. During maneuvering can the motors go as low as 0.07 or 0.09?

Should ATC_THR_MIX_MAX be adjusted as well?

You did something as it’s enabled and configured for throttle referenced notch.

.09

You can set it to .50 but you may not notice any difference.

I attempted setting up the notch filter once, but had some problems and have not gotten back to it yet.

ATC_THR_MIX_MAX is already at 0.5. Can it go higher?

Thanks for all the help. Hopefully I’ll get out test flying early next week.

Ah, misread that as _MIX_MAN, the only parameter you ever need to change in this group. Change that to .50

My understanding from reading the description of the params is that MIX_MAN is used during manual flight only, not during “auto” modes. If so, I suppose it wouldn’t help during my mission.
What do MIX_MIN and MIX_MAX do if they never need adjusting?

Sorry to be a pest, I’m just trying to gain a better understanding.

There is a good explanation of MAX on the Auto Tune Wiki page. Perhaps with props as large as yours it might be helpful to increase it.

You need to set this lower
INS_HNTCH_REF,0.22 to about 0.18

You probably want to use these unless you’ve got some special batteries
BATT_ARM_VOLT,44.30
BATT_CRT_VOLT,42.00
BATT_LOW_VOLT,43.20
BATT_FS_CRT_ACT,1
BATT_FS_LOW_ACT,2
(and same as above for BATT2)
MOT_BAT_VOLT_MAX,50.40
MOT_BAT_VOLT_MIN,39.60

And unless you’ve got T-Motor Flame ESCs you might want to try this
MOT_THST_EXPO,0.78
If this worsens the instability you’ll want to go the other way and start at MOT_THST_EXPO,0.4 and even as low as 0.2

Set these and just do some hovering for a while, maybe a few gentle movements
INS_LOG_BAT_MASK,7
INS_LOG_BAT_OPT,0
That will gather the pre-filter data for checking HNOTCH

After you’ve set all that, done a test hover to and some gentle movements, reassessed any params then need further adjustment - INS_HNTCH_REF , INS_HNTCH_FREQ , MOT_THST_EXPO - all these can affect each other and MOT_THST_HOVER.
Set INS_HNTCH_REF = 0.8 x MOT_THST_HOVER (this is not Dr Andys real formula from the doco but it works out close)
Set this and run a new Autotune
AUTOTUNE_AGGR,0.075

EDIT
On these big multirotors I think it’s appropriate to set FENCE_ENABLE,1 because you dont want this thing flying off to the sea of Japan or out of sight.
You wont be able to arm before there’s a good 3D fix, but you will have a reliable home position.
Test you radio failsafe too, if you havent already.

Thanks for all the help.

I made some the parameter changes as suggested and got things working better. Changing the PSC_ACCZ_ params got rid of the “surging” I experienced at light loads.

I also updated the MOT_THST_EXPO value based on my new MOT_SPIN_ params. I am using a t-motor alpha 80 ESC and I have some test stand data on it, so I plugged it into the arducopter spreadsheet.

Today I was just doing basic hover tests and the vibration was fine (~4x lower than the previous days), even with identical params. In all cases view the “post filter” spectrum it looks very clean. I need to run the more extensive tests again, and may come back for more help at that point.

1 Like

Thanks for sharing that sheet.
Once you are done with tuning please share a new log file if you can.

Did some more test flights today. It was better, but I did still see some instability. The wind was also calmer than the previous day, so this may be a contributing factor.

Here are the log files.

44.BIN - quick hover, pre-filter
45.BIN - quick hover, post-filter
46.BIN - speed runs
47.BIN - speed runs, ATC_THR_MIX_MAX and ATC_THR_MIX_MAN changed
48.BIN - auto tune
49.BIN - speed runs
50.BIN - figure 8

https://drive.google.com/file/d/1jCDpv3EUUUrYn4759pfmi-PBECnnVaqP/view?usp=sharing
https://drive.google.com/file/d/1jGDJt-4kHmM9AgE-Qbx__DA5oHJC59ov/view?usp=sharing
https://drive.google.com/file/d/1EblC876QJkSvr6zudxRbpm331P-fHsSj/view?usp=sharing
https://drive.google.com/file/d/1Zop44ObIHri8WsxkL7NTAHPrYo45gXL9/view?usp=sharing
https://drive.google.com/file/d/17wwZ_4BZbVcSThlTXlgejOPqDs8aX04K/view?usp=sharing
https://drive.google.com/file/d/1E9Hf3uz1CkC0SdEc3V29RJo8DcM9wCBS/view?usp=sharing
https://drive.google.com/file/d/1vXUCUcAvjXM1jS-4-i_JeUwy0GnrmJX4/view?usp=sharing

Harmonic Notch looks good, probably increase the number of harmonics covered
INS_HNTCH_HMNCS,7
and this can go lower
INS_HNTCH_REF,0.18 → 0.15

Generally attitude control is reasonably good

Log 47 has a “moment” where there’s oscillations that are only just handled, but many other other identical activities that dont cause those oscillations.

Log 49 has a couple of similar issues but to a much lesser degree

Roll and Pitch PIDs are quite different, I’d probably update those HNOTCH settings and rerun autotune.

The unexplained oscillation moments could possibly be an issue with those ESCs so you might want to experiment with these params to limit the stress on the ESCs
ATC_RATE_x_MAX (around 360 or 720)
MOT_SLEW_DN_TIME
MOT_SLEW_UP_TIME

Did some more testing yesterday.

First flight. Updated FW to 4.2.0 rc3, enabled PID logging, otherwise the same configuration as previous day. Problem was very subtle. 52.BIN
https://drive.google.com/file/d/1aFPAOahJrBMKEgPcU8iR2u4eu0ofQj1B/view?usp=sharing

Second flight. I shoved some dowel pins into the vibration dampers the autopilot was mounted on. Big problems, had to abort early. 53.BIN
https://drive.google.com/file/d/1WUktj03xVb3nWr5JwfGEVRQy7t-a4VIf/view?usp=sharing

3rd flight. Removed the dowels pins, some instability. Could just be due to the fact that the wind picked up a little bit. 54.BIN
https://drive.google.com/file/d/1sa6YVJZhydsCUbDsFPPLfiukqxXEBYFG/view?usp=sharing

4th flight. Set PSC_ACCZ_SMAX=100, was 0. No problems. 55.BIN
https://drive.google.com/file/d/1WkDQzoJjwAmxgC4mWpGxAJQ7Dy0pWFNK/view?usp=sharing

5th flight. Set PSC_ACCZ_SMAX=50. No problems, but had to abort just before the end due to the altitude drifting too low. fuselage is pulling a vacuum at high speed, causing altitude to drift downward. See the trend of baro alt vs GPS alt. 56.BIN.
https://drive.google.com/file/d/18b5Xc353FjV89LLQ3_zM8fT5l9Lb3x4L/view?usp=sharing

6th flight. Increased altitude of the last few runs. Same configuration, but higher wind. No problems. 57.BIN
https://drive.google.com/file/d/1-3eN8F_-Uu0s5-BDQujDICsKMWJfkakr/view?usp=sharing

Still need more flights, preferably in stronger winds and with fresh batteries to confirm, but it it seems like setting the PSC_ACCZ_SMAX has had a positive effect. I can see the PIDA->DMOD going below 1 in the later log files. It also seems like the extra vibration created with the stiffer dampers had a big negative effect.

During all flights, I had several notifcations when at higher speed, about “EKF lane switch”. Not sure if this is cause for alarm or not. This happened at much lower speeds with the stiffer isolators.

I’d like to hear your thoughts on this.

Increase the distance from the compasses to the rest of the electronics. Basically use a longer GPS mast.

Increase the distance from the compasses to the rest of the electronics. Basically use a longer GPS mast.

In regards to which issue? I don’t see a strong coupling between power and magnetic field.