Help requested to understand why no CAM messages on VTOL photo mission

A colleague from overseas asked me if I could take a look at his VTOL mission to help figure out why no photos were taken.

I’ve not used ArduPlane yet - but have done photo missions with ArduCopter. I thought maybe I could help - and learn something at the same time. So I agreed to help if I could.

I received the BIN file and the Waypoints file for the mission - and have uploaded both to dropbox.

I tried to run the mission in the SITL simulator (plane) but couldn’t get the aircraft to take off. So there’s my first opportunity to learn something.

I ran the geotag routine in Mission Planner against a directory with dummy image files - and it reported no CAM messages. That agrees with no photos taken.

I loaded the BIN file into MavExplorer to list out the MavLink messages - I saw nothing unusual to me.

The mission is set for 20 meters/second and photos every 47.6 meters - one photo every 2.38 seconds - so I doubt the cameras limits were exceeded - and besides - there were no CAM messages.

If anyone has a few minutes to spare - could you please take a quick look at these files and if possible, identify why no CAM messages were issued to trigger the camera shutter?

Thank you for your kind assistance!


My colleague reminded me that some photos were taken - just far fewer than expected.

I don’t understand that because the geotag routine showed no CAM messages. I need to check to see if I’ve received the correct BIN file.


I discovered that the BIN file I received has “TRIG” messages - not “CAM” messages.

I have a faint recollection that this may because of a different MavLink command to schedule the camera shutter.

In both the mission waypoints file I received, and the ones I’ve personally planned, we both use the DO_SET_CAM_TRIGG_DIST command.

However, my BIN files only have CAM messages. This one I’ve received only has TRIG messages.

So I’m guessing that maybe the waypoints file I received doesn’t match the BIN file I received with it.

It would be helpful to know what MavLink command actually generates these two different messages - CAM and TRIG.

If someone could please help me answer that question, I may be able to continue investigating this problem on my own.

Here’s the TRIG messages in the file I received:

There are hundreds of TRIG entries. I’m guessing if the camera failed to record all these images that maybe there is an issue in the hardware. Just a guess. With the mission planned for a camera trigger event only every 2.38 seconds, I doubt the problem is the camera - but it’s possible. If the camera is being triggered by an aux-port relay - I’m wondering if there is some sort of limitation on the frequency of the relay activations.