HELP PLEASE! Elevon Setup

I am setting up a Skywalker X8 with a pixhawk flight controller. I am relatively new to fixed wings and the Pixhawk flight controller. I think I have it about ready to go but am having trouble with my elevon setup. I cannot get the elevons to act right in any mode other than manual. In manual I have them working perfectly. But when I flip to other stabilize mode or FBW they do not work right. The aileron that is plugged into the aileron port on the pixhawk will work when I try to make the plane roll and when I make the plane tip the nose up or back the other elevon works as an elevator. I have messed around with the elevon mixing and the elevon output. Currently I have them set to mixing enabled and the output set to 4 which is DownDown. I can alter it and make them work in the stabilize mode but not exactly right and if I do that then the manual mode will not work. I think I must be close but just can’t figure out the rest. Any help would be appreciated. Thank you

Have you followed the steps to get the new elevon style mixing setup on this page? … evon-mode/

Thanks, Grant.

Hey Grant,

Yes I have been through this new style elevon mixing. I can get the pixhawk to act right in stabilize or FBW modes (i.e. servos move in the correct directions.) They work fine in these modes and I can get the plane to try and correct roll and elevation changes. However, once I flip the mode switch to manual is when I get the problems in doing it this way. In manual mode if I take the right joystick on my controller right or left it moves one elevon and if I take the joystick up or down it moves the elevon. It acts like it is not mixing the elevons in manual mode when I do it this way? I am using a service called drone deploy which should do everything automatically for me from takeoff to landing so I don’t really need manual mode but just thought it would be a good idea to be able to control the plane in case something goes wrong. I can’t figure out how to make it mix in all the modes.


This sort of thing is normally cause by reverse’s being mis-matched on the autopilot and the transmitter. I would leave the autopilot for the moment as its working the way you want and focus on the transmitter. What happens when your in FBWA and you move the sticks? Do the control surfaces move correctly? When in manual mode is there a way to configure the transmitter utilising reverse to have the behave correctly?
A log file would also help diagnosing the issue.
Thanks, Grant.


I have just the opposite problem. Manual mode works ok (direction of travel and working together) but when I switch to stabilize mode the elevons do not work together and it appears that one elevon responds to one axis change (pitch) and the other only to roll. I tried reversing servo leads, reversing channels but cannot get then to work in unison as expected in stabilize (ex nose down, elevons up; roll right, right elevon down, left elevon up). I upgraded from 3.2.1 to the new stable version and then went back to 3.2.2 no change. Checked and calibrated accelerometers no luck

Any suggestions?

here are some tips that I ran while setting up a couple elevon planes (using both APM and Pixhawk)…

First, get them working using just the RC Transmitter and Plane, no autopilot neded. (I usually fly and trim the plane here)

Next hook them up using autopilot, and make sure to RE Calibrate the transmitter in Mission Planner (Throws change with Elevon mixing enabled, unless you use 100%)…

Then set the ELEVON_OUTPUT option (this has 4 different options, UPUP, UPDOWN, DOWNUP, DOWNDOWN). Go through each one of these and confirm if the autopilot controls work properly in MANUAL MODE…

Next switch to STAB or FBW and check to make sure they STILL work properly, and if not go back into the RC Calibration page, and reverse a channel (The channels you would want to toggle are the Elevator, and Aileron)…

Its a semi pain, but this has worked through quite a few wings, but elevons are always a bit of testing and tweaking to make them work right…