Help Needed with Yaapu Lua Script and Telemetry Setup

Hi everyone,

I’m currently working on a drone setup using Holybro 5x, TBS Nano Diversity receiver, TBS CROSSFIRE micro TX V2, and running ArduCopter V4.4.3 firmware with Edgetx Providence on a TX16S remote.

I’ve encountered an issue while trying to use the Yaapu Lua script for telemetry. Although I’m receiving telemetry data on the TX16S, but the Yaapu screen displays a “No Telemetry Data” message.

Here are some key details of my setup:

  • Holybro 5x with TBS Nano Diversity receiver connected to Telem 2 port.
  • TBS Nano Diversity receiver’s CH7 and CH8 are used as MAVLink TX/RX.
  • Serial2_protocol set to 2 (mavlink2).
  • Rssi_type set to 3.
  • Rc_options set to 264.
  • Serial baud rate at 115.

I’ve ensured the physical connections, checked protocol settings, and verified firmware compatibility.

Any insights or suggestions on troubleshooting this issue would be greatly appreciated. Thanks in advance!

It seems to be an issue in the Script.
I have the same issue on a recently set-up Radiomaster TX12 Mk2 with EdgeTX 2.9 and ExpressLRS.
I have telemetry in the Radio but the Lua Script does not recognize it.

BTW: The Ardupilot documentation is outdated. ExpressLRS works perfectly for Telemetry.

The Yaapu script must be set to CRSF protocol in the configuration. Is this the case?

No, I don’t have the Yaapu Config in SYS/TOOLS like described here.

I used the installation guide.

I assume it’s what it’s labeled, BETA

Then you should install the script correctly:

Turns out the config lua is missing in the install package.

I’ll see how far I get with copying the .cfg file in models.

Nothing is missing in the install package and you don’t have to edit any .cfg files …

The installation is described here. You only need to go as far as the display configuration and select the “yaapu7” script there.

Then restart the transmitter and call up the Yaapu script with the TELE button. There you will probably see “no telemetry”. Then press RTN and TELE again and you are in the settings. Set “enable CRSF” to Yes at the bottom.

Then press TELE a little longer and RTN very briefly and you are back in the telemetry screen. Telemetry data should now be displayed when the connection is active.

If this is not yet the case, you must set the option “Use passthrough for CRSF telemetry” in the FC under RC_OPTIONS:


OK, that did the trick. Thank you.
I was not aware of this button combo.
After a couple of reboot action, the script actually does show telemetry but it comes with some bad side effect.
Apparently it changes something in the RF link and the FC looses RC thus switching to Failsafe in a 10-15s loop. It seems to “ask” FC for stuff like the ARM state and this switching around is fatal.

I run a BetaFPV 868Mhz TX module for long range 100Hz, telemetry rate Std 1/32.

Guess I’ll go back to the previous setup.
Thanks again. I hope this was also the answer the original author was looking for.

Set telemetry rate to 1:4.

Thank you, that got rid of the RC Failsafe Issues.