Servers by jDrones

Help needed setting up auto with arduboat

(Colin) #1

I have a pixhawk 2.4.8 and have set it up for manual as far as I can tell. I have all the parts assembled on a board which includes a pixhawk, gps module, receiver, bec, and servo. I have calibrated so when the board is pointing north it is indicated in mission planner and my campers compass. I can move the roll stick left and right and the servo turns accordingly. I have set the modes on chanel 8 for manual and auto and that works ok. I can set and write way points.
The problem is that when in auto mode the servo moves very very slowly and I have to be a long way either side of the way line for the servo to react. I have read many posts and I can not find how to make the action more sensitive. I have spent weeks on this and hence my need to ask for help.

(rmackay9) #2

Before jumping into Auto mode it’s best to get the lower level throttle controller and turn-rate controller working well. Have you tried tuning these?

If “yes”, then it’s probably best to include a dataflash log so that we can see more detail of how the vehicle is performing.

By the way, I’ve modified the category to “Rover-3.5” because as a “Blog” it was appearing on the front page of ardupilot.org.

(Colin) #3

I should point out that I won’t be using a throttle as the boat (torpedo) will be travelling at full speed. It needs to follow a straight way line taking a fishing line out to sea 1000 metres, I have no need to control the throttle as its controlled by a timer, at full speed. I just want it to head straight to a waypoint 2000 meters away. The timer will stop the motor before the torpedo reaches the waypoint. The line stays attached to the boat and is hauled in along with the fish.
The throttle controller and turn-rate settings are much the same as you examples. I will send a dataflash log tomorrow.
I only require to control a rudder to keep the boat traveling straight to the way point.

(Colin) #4

The dataflash logs fo the last two days.


(Colin) #5

I am looking at the steering settings. How do i set GCS_PID_MASK to 1?

(rmackay9) #6

@Colindo,

Most ground stations allow setting any of the parameters. If using the Mission Planner then there should be a Full Parameter Tree and/or Full Parameter List screen in the Config/Tuning section. If these screens aren’t visible try going to the Config/Tuning’s Palnner page and set the “layout” drop-down near the bottom to “Advanced”

(Colin) #7

I have been able to get some success using the apm 2.6 but what I find, the rudder servo wants to follow the target line and not the WP line. Is this what I should expect?
The target line is about 45 degrees away from the WP line.

(rmackay9) #8

Hi Colin, I guess the Pixhawk flight controller was replaced with an APM2.x board? I’m afraid I can’t personally provide support for the very old version of Rover that runs on the APM2.x boards…

(Colin) #9

I have a pixhawk 2.4.8 and I’m waiting for a new gps module to arrive. I’ll be delayed for a few weeks.

1 Like