Servers by jDrones

Help needed: cannot run in manual

Setup: MP 1.3.70, Rover 4.0.0, Pixracer with ESP wifi, FlySky fs-i10 Tx , tests run indoors.

A bit of history: Had problems with arming and resolved this issue by setting all parameters to default, re-doing initial setup, etc. Could run manually before setting all parameters to default.

Problem to solve: Cannot run in manual mode.

HUD shows this after arming:
pix hud safe

I have disabled all pre-arm checks and safety switch. I have never been able to do motor checks.

What does (SAFE) mean in the HUD? What did I miss?

Any and all help appreciated…

Post your parameter file, let’s see.

PixRover test.param (15.8 KB)

Can you attache the parameter file? Not just because pages and pages of text is annoying but I have a Rover with a PixRacer and can use the “Compare Parameter” function in Misison Planner to speed things along. You can edit your post and delete all that also :grinning:

Thanks Dave.
See file posted above.

Can you try configuring a switch for Arming and disable Arming Rudder? You should also enable Arming Check so you can see what problems are causing it not to Arm.

Thanks, Dave, but my current problem is that I cannot run in manual mode.
I can live with arming with MP actions for now, but I will try your suggestions and see if they affect manual mode.

Do you know what (SAFE) means in the HUD? I could not find any reference to it in the docs.

Update: Changed ARMING_CHECK from zero to one (all) produced no errors or feedback, but manual mode now works!! I will now check them off one by one to see where the culprit lies…

Servers by jDrones