Help: motors seem to run randomly

Hello everybody. I have this esc and this frame. the motors ( 33GB-520) seem to run randomly. How should I set the esc? I have tried normal and brushed but they don’t go with logic. FC Omnibus F4 pro ardurover 4.0. Motor test work only if setting throttle to 100%


You have to set the ESC type to normal for this ESC. I see the ESC has a mode switch for independent/mixed mode. You will want to have that switch set for independent mode.

1 Like

Thanks Sebastian, I tried switch in both positions. The results is that the motors test is in according with wiki, but the motors start moving only near to 100% of throttle. Why?

No way … :frowning: works only from 90% of throttle

I never use the motor test feature. I just change the trim value in the servo output screen to see if the motors turn in the right direction and start at the same PWM value.

in this position they begin to turn but one forward and one backward. It seems to ignore the reverse flag. After a few seconds they stop and I have to go back to 1500 otherwise they won’t start anymore. If I set the trim to 1500 the esc beeps and I can restart the engine bringing the trim value back to around 1850. But is there a way to calibrate these escs? Thank you!

How set this? Normal? Bipolar?


As I said, set it to “normal”.
I do not own this ESC, so I do not know if/how you can calibrate it.
I would not expect to much from a 5$ part.
“Reverse” takes effect after the FC is rebooted.
Perhaps it is some kind of safety feature, that causes ths motors to stop after the ESCs receive the same input for some time.

“Normal”… yes you are right!
Do you have any suggestion escs that might work on a tp101 mini tank? From aliexpress it would be better. Thank you!

I look this, so i think is good choice:

You might have a bad ESC. There are some reviews on amazon, which describe your problem with late start and bad resolution.

it’s not easy to find good cheap esc for small rovers :frowning:

Now works well, same ESC. :slight_smile:

1 Like