HELP : Motor #6 stops!

I am disappointed with the motor #6 which sometimes stops.
It stops, so the hexa go down, I try again, and it stops again after few minutes flight. I had this problem a the begining, and I disconnected the FC from an ESC BEC, and I installed a separated BEC. Then it works fine, so I though it was that. It worked fine for a month, and now, it do it again !

I changed the ESC, I changed the motor, I did a compassmot, I did an ESC calibration, I tried to set RC_SPEED to 400 instead of 490, nothing resolved this problem, I tried a reset.

My FC is an APM with arducopter 3.1.5

On the log, I saw that twice the motor (called “motor 5” even if it is connected on pin #6) stops, but I could not find the reason.

Please, can someone help me ?

Motor 6 in the log is the output labeled 6. The control signal is trying to drive the dead motor to full throttle and the opposite motor (motor 5) to zero throttle in order to control the copter. You certainly have a hardware issue.

A hexa can potentially fly with one motor out, but it also necessarily loses yaw control and may not have sufficient power to stay in the air.

Thanks a lot for your answer, I now understand why the logs show the motor #5 stops instead of #6. The joined image of logs shows that you said.

If my problem is an hardware issue, which one ? How can I find it ?
I changed the ESC and I changed the motor.

Can it be a bad contact with the GPS cable ?

Precisions :

My motors are a 710KV, I use 4S 5100mAh battery and 30A SimonK ESC.

Few times I had this problem, when I started the hexa, the motor #6 had difficulties to start, like bad ESC sync…
That’s why I tried to modify RC_SPEED from 490 to 400Hz, with no result.

The FC is supplied by a separated BEC on output pin #8, so I have the JP1 installed.
My BEC output is 5,34V : can I connect it to the input pin of the FC or is it too much ?

The ESCs are only connected to the board with the signal wire, and I saw there can be sync problem if the ground wire is not used…

Thanks, it was a hardware issue. I changed the ESC twice, but the new ESC was bad. The third was ok.

That is asking for it. Connect the grounds.