HELP: Mavlink cannot connect - "No Heartbeat" error

I have an ArduCopter 2.6 and I’m trying to configure with Mission Planner. I downloaded the most recent version and was able to walk through the Wizard the first time. I was having problems getting the ESCs to respond, and ended up using a new PC along the way.

On the second PC, I installed APM Planner 2.0 instead of Mission Planner, and then reloaded the Firmware. After realizing I wanted Mission Planner, I reinstalled Mission Planned and reloaded the Firmware. Now I am unable to connect to the ArduCopter 2.6 with Mission Planner - always get the “No Heartbeat…” message (where heartbeat is actually spelled “heatbeat”).

I’ve played around with the Baud Rate on the USB device driver, but that doesn’t seem to do anything. I’ve uninstalled and reinstalled 5 times, no luck. I’ve googled the hell out of this, and cant find anything to solve it.

Did loading a firmware with APM PLanner 2.0 screw up the Mission Planner’s ability to connect? Is there a way to just “format” or clear the ArduCopter 2.6 device so that I can start 100% from scratch?

Don’t think it mattered which product you used to load the firmware.

Since you were able to load the firmware the port must be showing up in the drop down. I think the baud rate is 115200.

Don’t know APM but on Pixhawk there is a safety switch that when you hold it down and power on the unit it goes into boot loader mode and you can reload the firmware.

Mike

I’ve tried playing with several different baud rates, and no luck. I’ve reinstalled everything, removed all the drivers from the USB and PORTs in the Computer Manager, but still no luck.

I have a 3DR radio and tried to configure that to connect Mavlink with instead of the USB cable and I’m having the same issues. I’ve ensured all the drivers installed (had to install some manually - no yellow trianlges). With the Radio, I’m able to go into MP and under “Optional Hardware”, I can get Load and Save settings, but I still cannot connect to the APM thru MavLink.

I’ve been googling this for 2 days and no help. I see a lot of posts of people with the same problem and a lot of advice on things to try, but seems a lot of people run into this with little or no luck in fixing.

This worked once, and then just stopped. I don’t think it is related to my computers, because I had it working on computer A, then went to computer B and it stopped working, then went back to A and it doesnt work there anymore. The problem seems to be on the APM itself.

Does anyone have a definitive list of things that should be checked to ensure this works, or is it possible that he hardware is just that unreliable and needs to be replaced. If that is the case, then what caused it to die?

@craig18,
Have you tried different USB cables to eliminate the USB cable as being faulty?
Regards,
TCIII GM

Just tried that - no luck.

I completely rebuilt my PC to make sure that the PC was not the problem. Here are the steps I just took.

  1. formatted HD on PC
  2. Installed Windows 7 64-bit, and all necessary drivers (video, USB, wifi, etc)
  3. Installed .Net 4 framework
  4. Downloaded and installed Mission Planner from here (ardupilot.com/downloads/?did=82)
    • several more drivers were installed
  5. Launched Mission Planner (1.3.20 build 1.1.554.30869)
  6. Using a USB cable (and I’ve tried more than 1), I plugged the USB cable in my PC and the ArduCopter v2.6
  7. Inside MP, clicked on “Initial Setup” and then “Install Firmware”.
  8. Selected the COM3 option with Arduino Mega 2560 (COM3) in the dropdown.
  9. Clicked on the Quad picture (ArduCopter v3.2.1Quad) and the firmware was loaded successfully.
  10. Selected “Config/Tuning”
  11. Pressed the “Connect” button.

!!! Message about timeouts and eventually the Hearbeat !!!

Using Device Manager, I ensured that the device called “Arduino Mega 2560 (COM3)” listed under Ports (COM & LPT) has its Bits per Second se to 115200, and the dropdown in MP is the same.

I also have a 3DR Robitics 915 MHz radio and connected that. I ensured all the drivers installed for using (following several examples I found using Google), and I disconnected the USB cable. I plugged the battery into the Power on the quad and the green lights on both radios (PC and APM) are solid green. When I select the Radio COM port (COM4) and press “Connect”, I get the exact same message.

WHAT THE ??? Should I get a hammer and smash the APM to pieces, or is there another solution that anyone can suggest?

Well, I did find in the code where the message is coming from and it is miss spelled more than once in module “MAVLinkInterface”.

From this I gather that everything is working except your APM 2.6 board. The firmware must not have loaded correctly the last time or is not working. The software uses Mavlink to talk to the board and yours is not talking.

Did you try and reload the firmware. It may have just not load correctly the last time or your unit may be bricked.

Mike

I tried installing firmware for every type of device available in MP and MP says that they all install successfully. I finished by reinstalling the v3.2.1 Quad firmware and then tried connecting with the Terminal. When I do this I get

Init ArduCopter v3.2.1 (36b405fb)

Free RAM: 1999
FW Ver: 120

load_all took 1724us
PANIC: AP_Bara_MS5611 took more than 1000ms to initialize

Per several other posts, I took a voltmeter and measured the voltage across the pads labeled “3V3” and “5V” while its plugged into the USB and both show less than 1 V (almost 0).

Does this mean its bricked? I just bought this a few months ago, so I assume its still under warranty.

I don’t have an APM unit so I don’t know, but there is some LED’s on the board and one is Green that should be on if the unit is working. Don’t know for sure.

Bricked is another issue where the firmware is really hosed. Your case is the unit is fried.

The fact that the firmware loads tells me that it should have power though.

Mike

I went from apm planner to mission planner and had the same problem. I discovered the problem was in the advanced parameter settings, it was not set to 57600 baud and that’s why it wouldn’t get the heartbeat when using the telemetry radios…

Correction I meant the standard parameters in mission planner…

Hi All :slight_smile:

I am ALi, from Malaysia, I also have the same problem like craig, same flow as i had MP installed at first then i installed the APM Planner, then it cant connect though telemetry. was there is any sollution for this? i just have this unit 2 weeks, and i can confirm that it is working for the last two weeks until i manage to run it through APM Planner and i found out i need the MP instead of APM Planner.

any help would be much appreciated.

cheers!
-ALi