Help! Holybro telem radio "A device attached to the system is not functioning"

I bought a set of Holybro v3 telemetry radios, plugged one into my pixhawk 2.1 (black cube) and the other in my windows computer set the baud rate to 57600, and I had to install a driver with zadig because my pc didn’t install one. The only one that would seemed to work is “USB serial(CDC)” so I selected com3 and hit connect and this is what I get “A device attached to the system is not functioning”. I know their communicating to each other because both are solid green with red flashing simultaneously, I’ve tried it on an other pc and get the same result. Any help or suggestions from you smart people is greatly appreciated! Thank you!!

Capture telem

I wish I could offer good advice but I am just going to add to your frustration. My new purchase of holybro 500mw system waisted a few days of my time. My issue trying to chase a driver issue, the decive not being found. The reason I am replying here is to save anyone else the trouble. I purchased MRO sik antenna setup($38.00) for testing to see if it was my 3 different computers and it worked like it should. I ended up with RDF 900x because they are not made in china and I wanted to test some advanced features. My advice is to avoid HolyBro, it appears quality control is lacking or maybe just pushing out poor products, Lately my experience is china is dumping garbage, I expect it’s because the US is finally realizing china is not our friend

Well thanks for the reply, I also tried the driver from the chip manufacturer ftdi with no luck. RIP $50:( if anyone has any ideas I’ll still try them!

Just curious.
Have you checked the pinout? Some radios from that region have had the pins wrong. After a swap of cable pins it did work.
This is not what I have experienced personally just did read it somewhere ??, some time ago.
Good luck!

Had similar issue, make sure you install the right driver, and make sure your usb cable is data too, not only charging!

I just had this issue and was trying to use this forum to trouble shoot. I got mine to work by uninstalling the driver and then going on the manufacturer site and installing the latest version for windows 10. If you are using a windows computer go to device manager/Ports(COM & LPT)/USB Serial Port(COM)/Uninstall Device. Then visit this link and follow the instructions for installing the driver.

I don’t know how to check that.

When I use the automatic installer it doesn’t seem to change anything, and if I try to install them manually it says Your device already has the best driver, or something like that. Thanks for the help everyone!!

The cables should be good, i’ve tried the one that came with it and one that came with my pixhawk. Which driver did you use?

I used siliconlabs driver for windows, just Google that and download! Look up a tutorial on how to install drivers on windows through device manager. But your telemetry may use different USB driver because mine wasn’t holybro