Help getting ESC to work

I have a rover with separate steering and ESC motor control. I can not get an ESC to work in this setup. I have an RC truck that came with an Armma Forward/Brake/Reverse ESC. I’ve read that can cause problems so I purchased a Hobbywing 1060 and made sure it was configured for Forward/Reverse only and I still can not get the ESC to activate the drive motor in manual mode.
I have pixhawk 2.4.8 (FMUv3) with rover 4.0 flashed on to it. I have activated the safety witch and manually, fully, armed the controller. Now that I installed the Hobbywing ESC I can see the signal accurately reflected on the Throttle in the Servo Output screen. I was never able to get that while using the Forward/Brake/Reverse ESC.
I have calibrated the radio servos. I have ensured that I have full 3d lock for the GPS and I don’t see EKF in red on the HUD, so I’m kinda confident it’s good. This is my first attempt and anything ardupilot so I’m new to this hobby. I have read through the Wiki and watched a lot of youtube. Am I missing something? How do I determine where my mistake or fault is? Guidance is greatly appreciated
Thanks in advance.

The Armma ESC probably would have worked. I have used stock RC Truck ESC’s no problem. But the Hobbywing is fine, used those too.

This doesn’t make a lot of sense. The FC doesn’t know what ESC is connected.

Thanks for responding.

Here is my full parameter list.

I have not directly modified anything. Did read a few things about changing a setting based on the ESC type, but did not find enough information to give me confidence to try anything.

panslab_rover_full_paramater_list.txt (16.1 KB)

Set the MOT_PWM_TYPE back to 0 (PWM) to start. I would just disable the Safety switch. ESC connected to output 3?

Yes, the ESC is connected to output 3. Steering on output 1. Steering does work. Not well, it’s not smooth and it tends to run when the safety switch is enabled, but it works. I failed to mention that this is a brushed motor. I also forgot that I had changed MOT_PWM_TYPE to 4 while trying to get the original ESC to work. It was at 0, didn’t work. Change to 4 still didn’t work and left it that way. That’s what I get for not making notes.

I set MOT_PWM_TYPE back to 0 and got all the GPS pre-flight to go green and still the same behavior. I’m still using the Hobbywing ESC. I see the Throttle output change on the Servo Output page but nothing from the motor. The ESC just blinks after initial power on.

Well sure, but the ESC you have, and the stock one you have, both accept standard PWM. Is your throttle at mid stick when arming? Disable the safety switch.

That was it. Thank you.

Can you help me understand why that matters?

Because those ESC’s are no different than most other ESCs’ for multirotor or Planes for control input. The input requirement is standard PWM, the output is for a typical brushed motor. You set that parameter based on the control signal requirement not the motor output.

I have now tested with the original Armma ESC also and both work. Thank you for your assistance.
Now I’m wondering why do I have to disable the arming switch? How does that change the pilots behavior to enable it to work with the ESC?

You don’t have to disable it. Use it if you like. I quite using that feature years ago and now many Flight Controllers don’t have the feature available. But, up to you.

Hi @dkemxr,

Maybe you can help me. I also newbie to rover. I made a setup using Navio2 + Roboclaw 2x7A (RC mode) + 2 brushed motors to a Skid Steering rover.
As said in docs pages, I setup roboclaw as BiPolar MOT_PWM_TYPE (4).
However the motors don’t move.
I tested the set drive/motors with a servo tester (pwm) and does it work well (pwm low reverse / high forward).
So I set the MOT_PWM_TYPE back to 0 (normal) and the motors moves, but only in reverse way (doesnt matter where is the stick).
Servo 1 is 73 and Servo 3 is 74.
Anything else needs to be set up?

I’m not familiar with Roboclaw. I often wonder why these are used when RC Truck ESC’s are relatively inexpensive, waterproof and simple to configure. But anyway, as you have discovered if it’s set for RC mode this logically would be PWM so that’s what you want for the TYPE.

1 Like

I’m not at that point yet. I’m doing my learning on a small scale setup before I try to use my large scale project. I have a mobility chair that I want to have autopilot control of. I have the 65amp version of the roboclaw controller on it to handle the stall current.
Have you tried searching for help on ardupilot skid steering?

1 Like