Servers by jDrones

Help connecting Raspberry Pi 3B+ to PixHawk... wirelessly

Can someone help point me in the right direction. I am attempting to connect my Pi 3B+ to a PixHawk wirelessly. I have gotten through the info on this site on how to set it up (it has some errors in it I believe… at least for my set up it wasn’t working). But I was able to cobble together info from multiple sites and finally I got the Pi via Mavlink to talk to the pixhawk with 4 wires (ground, power,TX, RX) connected. I can send commands back and forth, arm it disarm it, and the link works great. But for my project I need that link to be wireless so I am trying to use an RFD 900+ modem radio to connect the pixhawk and Pi but I can’t get it to work, it just says that the link is dead. Both of the radios (one on pixhawk and one on Pi) both go green solid and it looks like they are connecting to each other but there is no link, it’s like the radios are connected but the Pi via Mavlink is not connected to Pixhawk or not sending the right data or format or something. I figured if they were talking while hard wired it should be pretty easy to just put an radio in between. Is there some kind of settings in Qground Control that I need to do or is there something more I need to load on the Pi to get it to package it the way the radio can send it? I am using 56700 baud rate set on Pi and QGround Control. Anyone know how to fix this I can only find threads on how to fix wired connection where Pi will fly on aircraft, my Pi needs to be not hard wired and separated from the aircraft

Is the telemetry port on the Pixhawk set to 57600 too?

Yeah sorry 57600 baud rate set up on Telemetry 2 on the pixhawk/QGround Control and then same baud rate on Mavlink/Pi. Works wired but not when I connect radio. Also tried 921600 on both, again it worked wired but not when I plugged the radio in.

Also once I am connected where can I find a list of commands that I can send to the Pixhawk via the raspberry pi

I want to use the command line and send commands directly to the pixhawk but I can’t seem to find a simple document with explanations of how to use the commands. All I can find is documents that are written for programers with very complex descriptions with tons of acronyms and all kinds of other things that don’t make sense to a beginner.

I believe pixhawk baud rate is set to auto negotiate with the rfd on vehicle side. But on pi side, baud rate set in settings for the rfd must be used. As long as the rfd displays solid green light, there is no reason why it shouldnt be connected.

Also, please confirm the rx pins go to the tx pins and vice versa on both vehicle and pi side. It should work.

For better diagnosis, please upload your physical setup as well.

Servers by jDrones