Help about using dshot on tail rotor


I downloaded it, and tried. It fixed the failure on boot with ESC telemetry. But, again, the problem I described in the beginning in version 4.0.7 of dshot output with motor4 function shows up. And like mentioned, the board created two new COM ports and BLHeli Passthrough always denied by ardupilot.

You must set SERVO_BLH_AUTO for passthrough to work

I see, but why is there two new COM ports?

BTW, the boot failure seems also happens on other boards. Same thing happens to a kakute mini f7 board of mine.

New COM ports are for H7 - SLCAN and Mavlink. It is normal on many H7 boards.

Boot failure can be caused by a lot of things.

Can you post your full parameter list and what you are expecting to happen but is not?

@bnsgeyer I notice in the code that there is no provision for MOT_PWM_TYPE even though we construct an overall motor mask. Is this intentional?

kakute.param (18.1 KB)
I was trying to use a kakute mini board instead, so I did same thing on it, setting SERVO_BLH_MASK, SERVO_BLH_OTYPE and SERIAL7_PROTOCOL. After save and reboot, the board keep rebooting itself repeatedly.

Thanks - I mean the motor4 problem. I am not understanding and need to see your setup.

@andyp1per this is a part of the code that I am not familiar with at all. From what I know, heli doesn’t use any of the MOT library. It’s always been that way and I am not sure what that affects and how it affects what we do with heli’s.

After recheck, all aforementioned problems gone, except BLHeli passthrough still denied by ardupilot with SERVO_BLH_AUTO set to 1 and the SBus receiver not auto detected which makes me have no means to tell whether the motor works.

1 Like

just check the dev build you attached and now it boots normally. The ESC telemetry is also working, but I cannot get connected to the MatekH743 because the S.Port is not working. I check the F.Port this works just for a minute and then it crashes and AP turn radio fail safe on. This means I could not try if the Dshot is really working.
Thank you!

On this board if you have had any kind of watchdog you should reinitialize the flash by setting FORMAT_VERSION=0 and then reloading the firmware. You will then need to reload your parameters.

I have enabled the Radio control by setting corresponding serial port, but I have trouble in arming it. Is there any other ways to control the two motor without arming it? Setting servo_function to RC_IN does not not work.

I don’t understand the question

As I want to test the two motors to ensure they work under dshot setting, I need a way to direct control the throttle of them, since I got a problem on arming it and test them in the normal way, that I got no response from controller when arming it.

Hello @andyp1per I am not able to connect the radio using FrSky S.Port. AP is not able to decode it. I tryed the above advice of Format_version=0 but nothing changed. It cant decode the S.Port and also the FrSky S.Port Passthrough telemetry is not working. I tried the Heli latest dev version and is also not working. It also doesnt work in the Heli FW version without Bdshot. If I load the Heli Stable 4.0.7 its working. Somehing is wrong with the RCIN. I believe @zlinaz is complaining about the same issue. If I set the SERIAL7_PROTOCOL=10 + SERIAL7_OPTIONS=7 S.PORT Passthorugh is not working. If I set SERIAL7_PROTOCOL=23 I have radio connection but no telemetry. If I set SERIAL7_PROTOCOL=23 + SERIAL7_OPTIONS=15 the F.PORT is decoded but just for a few seconds. Thank You!
Heli_Parameter_B5_test.param (20.8 KB)

Sorry, not my expertise - you need input from either @tridge or @yaapu

1 Like

Sorry, don’t know - maybe @bnsgeyer can help

I am not familiar with what @Pedro_Claro is doing. I do not use FrSky or ESCs capable of dshot. I saw that he started a new post. Hopefully @rmackay9 can help.

Hi, sorry for not responding earlier… I’m going back through all the older reports on the 4.1 issues list to be sure we haven’t missed any.

I guess in this thread we have two reports:

  • @Pedro_Claro : says that FrSky S.Port does not work and F.Port only works for a few seconds
  • @zlinaz is using a matek h743 and kakute mini and cannot get all the heli tail rotor to use dshot if the tail (motor?) is connected to the autopilot’s servo out 4.

I’m wondering if @Pedro_Claro and @zlinaz could confirm that they are using 4.1 and if yes, could you provide onboard logs? We should also consider moving these discussions to two new topic to the Copter-4.1 category.

OK, I think I’ll consider this issue closed but I’ll be monitoring for replies…