Helicopter throttel cut off (CH8) during a mission

Hi everybody,
during a mission my helicopter cut off throttel and i don´t know why.
The cut was between the minute 13:15 and 13:16.
Attached log an Tlog. Any help will be appreciated.

Thanks in advance.


Check this out if that fits your problem or not.

Problem with RC Passthrough mode of the rotor speed controller in AC 4.0

You have the throttle curve selected but the throttle signal in exactly matches the collective signal in from the RC radio. Which tells me you have a very strange setup that has never been seen before

Hi Loren,
Your log shows that you have H_COL_MID set to 1500 with H_COL_MIN set to 1400 and H_COL_MAX set to 1652. What collective blade pitch does your H_COL_MID equate to? Your log shows that the aircraft thought it landed and that is why it shutdown the motor. It appears that maybe you set the H_COL_MID parameter too high. It should be set to a value that equates to zero rotor thrust.

Thanks Fred, I will read your recommendations.

Hi Chris,
I have selected on my transmitter: Helicopter mode with H1 swashplate.
Channel 3 and 8 are supposed to be synchronized, or is that not correct?

Hi Bill,
I have this parameters:
H_COL_MIN = 1400 = -4º
H_COL_MID = 1500 = +3º
H_COL_MAX = 1652 = +13º

I have changed the values and will test them later:
H_COL_MIN = 1370 = -6º
H_COL_MID = 1525 = +4.5º
H_COL_MAX = 1652 = +13º


@ChrisOlson Loren has the motor interlock set on RC channel 7 so RC channel 8 is not affecting that. So everything there is fine because RC channel 8 isn’t set to any function.

@Loren_DS this is an incorrect set up. DO NOT FLY THIS SETUP. like I said earlier, H_COL_MID must be set to a collective value that corresponds to zero thrust so that means the collective blade pitch should be zero for symmetric blades or something less than
zero for asymmetric blades. Please correct your setup.

1 Like

ok Bill, change H_COL_MID to 0º.


Yeah, I know. But I added throttle output logging in 4.0 with the governor, and that is logged regardless of whether or not the governor is used. It is the control_output in the RSC. The throttle curve is selected for the mode.

The throttle output is inverted and it is following some strange setup I have never seen before. That is not immediately apparent even what this setup could be.

So now I look at the mission part, there is no idle used, so can’t be a piston engine. Must be electric. But it is using a pseudo piston throttle curve. With zero throttle on the bottom of the curve. And the input to the ESC is inverted? There’s no way this can fly.

So then I looked at the RC8 in and see this tie from the collective to the RC8. At that point, rather than make an assumption I just say it is a very strange setup. My suspicion is that the throttle is hooked to the receiver RC8 output and that’s how it was able to fly.

@bnsgeyer Bill, the other possibility is that maybe it is starting at full throttle (due to the inverted throttle signal)? And then as the throttle curve advances it actually idles it down to around 60% power?

I really don’t know. It is very strange.

Reversed throttle signal is common on piston engines where you need to make the throttle servo go the right way. Never seen it on an electric before. The only way I can see where it would have anything close to a normal throttle, be able to initialize the ESC, and actually fly is if that RC8 signal is being used for the throttle. And I thought maybe that’s the purpose of the tie between the collective and RC8 in.

Otherwise I am confused as to how it even got off the ground.

I’m always concerned about issues in the code we had no control over, such as moving the switches.cpp to the RC_Channel object, and this causing some problem that was not caught. I hate this moving around of stuff just to re-write existing code that already works, and then the possibility of introducing bugs because it was only tested in SITL. But in this case I think there is a very strange setup causing the issue, and nothing wrong with the code.

@Loren_DS are you using a piston or electric engine to power the heli? Is the engine control (servo or ESC) connected to the flight controller or the receiver?

@ChrisOlson everything I am seeing seems to point to the aircraft disarming because it thought it landed. Also if he connected his throttle control to the receiver then it should have never shutdown the throttle when it disarmed. Meaning the receiver would have kept the motor running.

Yeah, it thought it landed, but I see the activity of the aircraft following what was happening on the collective/channel 8 RC signal. The throttle signal on the RSC channel (8) is impossible.

At the point where it lost power the actual throttle signal was over 80% power. But the pwm signal was only at around maybe 15% power. That is why I am confused. Need the details of how everything is hooked up to determine how it could’ve worked or gotten off the ground that way. I am not aware of an ESC that can run with inverted signal. And I don’t think it can be piston power because how was the engine started and allowed to idle before it took off? You need the throttle curve to run up a piston because you have a clutch to get engaged and get stuff turning. That does not happen in the few seconds I see from motor interlock enabled. Even at full throttle it will “lug” the engine while it labors to get rotor mass turning during clutch slip.

So I think it’s electric. But then I have more confusion as to how it worked with the inverted throttle signal.

The helicopter have a piston engine (100cc)
Rx is a Futaba R7008SB / Tx Futaba 18SZ and all channels connected with Sbus.
The throttle isn´t hooked to the receiver RC8.
I made several flights in acro / AltHold / Loiter and there were no problems.
I have seen in my LOGS that at the time of the engine stop there was also an “RXerror”, can this be the cause?

How did you get it to idle with no idle setting? And the bottom of the throttle curve set to zero? That is not right for a piston engine.

@bnsgeyer is it included in the wiki how to set up for piston engines? It is really not any different than any conventional FBL unit setup, so it should be pretty much self-explanatory. But the engine needs an idle speed, and the bottom of the throttle curve should be flight idle power.

I think the problem here is improper setup of the throttle curve. It closed the throttle and shut the engine down.

@Loren_DS can you provide some details of your setup?

  1. Can you shut the engine down by cutting the fuel flow? Or do you have the idle speed set with a idle stop screw on the carb?

  2. The engine in that heli is likely not magneto ignition as normal aircraft engines are. I suspect it is battery-powered CDI. If so, which channel is the ignition on? And how is the ignition switched? PWM signal to the CDI unit, or RC-operated relay?

  3. Which channel is the starter on?

I want to understand, first, how you got it started, spun up and into the air with no normal fuel control setup required for helicopter engines.

I should mention, Loren, that it does matter if these other controls go thru the flight controller or not. Only throttle control has to absolutely go thru the flight control. I do recommend having a backup engine shutdown method for piston power, as throttle servo’s can and do fail. If you get a failed servo with a piston engine and the throttle is stuck, there is no way to shut the engine down except by killing the mag(s) or cutting the fuel flow. On our piston heli’s we have fuel control selenoids that turn on the fuel, and the control for that fuel control does NOT go thru the flight control. It is hooked direct to the RC receiver so the engine can be shut down independent of the flight control (for safety reasons).

This is a very hairy experience having a failed throttle servo with a magneto-fired piston engine and not being able to shut the engine down due to the stuck throttle. This also requires a different failsafe setup - you can’t use No Pulses as No Pulses is only for flight controls, not external engine control components.

So once I know what you have presently that made it possible to get it in the air, and can determine whether or not it was the ignition system that actually killed it, then I can recommend a proper setup for your style of piston engine (which I assume is a F-100?).

that’s right i don’t have idle power, because the first tests I did in acro mode and it is easier to stop the engine in this way.
I understand that even if it had idle power, the helicopter would still have had a stop because the clutch would be off.

  1. Can you shut the engine down by cutting the fuel flow? I can stop the engine with Motor Interlock switch (CUBE CH7) or RCexl Kill Switch for emergency (Rx futaba channel).
    Or do you have the idle speed set with a idle stop screw on the carb? NO

2.The engine in that heli is likely not magneto ignition as normal aircraft engines are. I suspect it is battery-powered CDI. If so, which channel is the ignition on? spark plugs connect from a switch on the frame.
And how is the ignition switched? PWM signal to the CDI unit, or RC-operated relay? PWM to CDI.

3.Which channel is the starter on? CUBE CH6 assigned with CH11 in my Tx

Yes, is F100 oil System.

I suspected the starter is on 6. I saw the signal for that. So if I understand correctly, the ignition (CDI) signal does not go thru the flight controller? That is hooked direct to the RC receiver? Which would be good if it is set up that way. Actually the starter should be the same way, there is no reason to run that thru the flight control. Both of those items can be controlled via pwm signal from the receiver.

For the throttle, there is a H_RSC_IDLE setting. This normally sets the engine idle speed with the flight control armed. Then the throttle curve 0 point should be set to a value that engages the clutch when you flip the Motor Interlock. There is two timers, a ramp and runup. The ramp is the important one - it will determine how fast the throttle increases from H_RSC_IDLE to throttle curve 0. Then the rest of the throttle curve should be set accordingly.

The reason you do not want the throttle curve 0 to be at 0% throttle is because if you lower the collective all the way in flight it will cause engine shutdown. Different pilots like the throttle curve different for runup, but typical throttle curve would be like 22-30-38-65-100 for a piston engine.

Technically the bottom (throttle curve 0) setting is called Flight Idle. It is the lowest permissible throttle setting in flight that keeps the clutch engaged and the engine warmed up (so it doesn’t shock-cool for a piston or flame out for a turbine) if the collective is lowered all the way in flight.

The H_RSC_IDLE setting is called Ground Idle or Low Idle. It is the engine’s idle speed with clutch disengaged. In flight you should be able to throw the Motor Interlock (usually called Throttle Hold) and autorotate the helicopter with the engine idling at Low Idle. The way you have it set up now, if you throw the Throttle Hold in flight it will shut the engine down.

The engine’s Low Idle (or Ground Idle) is enabled/disabled by arming/disarming the flight control.

If the throttle servo fails either in flight or on the ground, throttle becomes stuck, your PWM ignition signal from the RC receiver can be used to stop it. That emergency stop should never go thru the flight control. If the flight control locks up or stops functioning and the helicopter was trimmed out for cruise it could potentially fly off into the sunset if you don’t have a backup method to kill the engine.

ok Chris, thanks for you information.