Heli simulation problem

Hello friends

I have a question in a long time.

I am very embarrassed because it was not a problem before.

I want to simulate a helicopter.

It was very good in the past, there was no problem.

But I wanted to run the simulation today, but I get this error message.

Is it necessary to grab a virtual pixhawk and do an acceleration calibaration (joke)

The motor interlock problem also annoys me.

This one day will come up and one day will not.

There are no rules, so we can not infer what is wrong.

I’ve moved this to Simulation so the right people can see it. Good luck!

Check your INS_ACCOFFS_X, _Y, and _Z for all instances. They should be 0.001. The INS_ACCSCAL_X, _Y, and _Z for all instances should be 1.001. Also your ARMING_CHECK param should be zero.

In the sim, if you don’t have a transmitter/joystick hooked up to mission planner, then you will get this message as the default state for the motor interlock is enabled. You have to set it through MAVLink if you don’t have a joystick hooked up.

Hope this helps.

Hello Bill

I have solved this problem

Solved the accel cali problem by setting arming check to 0, solved the motor interlock message by adjusting the min, trim and max values ​​of servo(number8) output

But this time another problem occurred.

When i try to start the mission, i see flight mode change failed.

I have often seen this error message on my real heli.
But for whatever reason, I do not know if this is happening.

Hi Bill!

I brought good news !!

I was successful in the simulation flight.

The problem was that the simulation was very simple, Mission Creation - Upload - Arming - Mission Start

But now, the way I succeeded is very difficult.

rc8 Set all min, max, trim values ​​to 1500 and arming
And change the min value to 1400
That way, i can change the mode and start the mission all the way - without the phrase flight mode change failed.

I do not know why I’m a beginner, I do not know why it’s solved this way.
But is not there something easier?