Heavy Y6 adventure thru 3.4 RC with AutoTune

Rainer,but what to do…on my AUW 7kg Y6 and 10kg X8 I have only Pixhawk …and RC(especially rc6) version is much improved to a year old 3.3.4…on my 16Kg monster i didn’t decided about AutoPilot yet…for now i am just testing on Y6 whose behavior i know very well…
In the meantime i am having fun with my Phantom 3 while i am waiting for Mavic…i just hope my big birds won’t need DJI!

Emin

2 years ago I had a bad experience with beta. Copter went to 2800 meters to the lipo empty, crash

Emin,
i also fly a y6B with 3,5-4,5 kg AUW.
I never managed to get good results out of autotune, so I decided to tune the PIDs manually, what is really easy with parameters put on a knob of your FC.
There are good guides to tuning AC and you will get much better flight performance. I think autotune is optimized for standard setups (quad 2 kg) and will not work with larger and exotic machines like yours.
Many thanks for sharing your frustrating experiences - I also like to try new releases, but for productive work (agricultural mapping) I still use 3.3.3 which offers everything I need.

Hubertus

1 Like

Thank you Hubertus…i never thought of Autotune as dependable on what type of a craft…autotune try just the same thing you do manually,what is maximum acceptable value…in the past autotune was ok,even on this Y6…i must admit i do not use manual tune since autotune is here last few years…
In my last AT there was one short moment after pitch and before roll tune(separate) when Y6 was exactly how i want him,1m,7kg craft was responsive as Phantom…but that value was 10x(1000%) times bigger than usual…i am sure something else is wrong,not AT…
I wonder where Leonard Thall is…he is the one i need…if anyone knows him please say some kind words…

As one of the members pointed me,it is not clear what my questions are…i manage to solve almost all but there is few left so i will try to summarize…

  1. What about very fast disarm/arm msg i heard from mission planner in 2 out of 15 flights,while craft was in the air?!Maybe it was more bcs. voice was not on all the time…

  2. Why are the values I got from AT 10x times (1000%) bigger than usual(also with first AT was 2x(100%) bigger)??
    Also during Roll AT it seems to me Y6 leaned for test to one side more than another…

  3. If i use double LiPo, 4 instead 2 (40Ah vs 20AH) as dummy weight and also connected,could this significantly effect results of AT?I will fly with 20Ah and gimbal instead extra LiPo

  4. What about ESC calibration?
    Two of them calibrated minimum 1028 instead 1024 like all others(max is 2020 on all) …
    Should i set all to same min value?
    In Mission planer min-max is set to 1000-2000)
    PPM centre throttle(in ESC BLHeli settings software) is at 1500 when actually mathematically middle is at around 1525…default BLHeli settings is 1488…but i don’t use central throttle,is this important at all?
    PLEASE TAKE A LOOK AT BLHELI SETTINGS IN ABOVE POST…

  5. Why my Throttle Accel IMAX is 5 where should be 80 or some 2 figure number?

  6. Could some of this problems be connected with my Windows 10 tablet,don’t know how,everything is working well,but who knows?
    What about Pixhawk memory card,how big or fast it should be?class 10 4 GB ok?many things are enabled in logs?..my Pix is original and old,ROM is only 1GB…i remember something like that and logs…

  7. What could change between 2 flights;one was Autotune of 17+ minutes motors were just slightly warm(almost body temperature) and in my next flight 5 minutes long they were double that?

  8. How can i start Autotune from the values i already have?
    Is it parameter AUTOTUNE_MIN_D or there is something else?

  9. What about changing in altitude values from baro if copter just rest on the ground for some time?
    8 meters in 30+min in my case,copter had some 8 GPS thru window and HDOP around 1
    also i noticed that before when i left it in the field not flying…
    also showing negative altitude values after landing in alt hold as well…

  10. Why Mission Planer AutoAnalysis showing problems it does not exists?VCC Warn…
    Also some other values are NA (i guess Not Available)…autotune,balance/twist,PM,Pitch/Roll,Thrust
    Can we make this tool somehow better,graphical maybe similar to Forest excel sheet?

  11. What about GPS/compass,accel signal from AP to gimbal thru mavlink to avoid horizont drift in extreme situations?

  12. Where is Leonard Thall one of the authors of Autotune,man who knows it like his pocket?

  13. Who will be responsible for answering questions about Pixhawk 2 problems and where that will be?

Hello Emin,

For a minor preface let me say that my experience far below of experience of developers here. So everything here is just IMHO and I could be totally wrong. Hope people will correct me in this case.

  1. I believe here is some chance for issue in MissionPlanner or something like that. Do you have seen that topic? Disarm/Arm in the air

It seems guys there have got a real crash due to disarming in mid air. But it happened just once and there is a good chance it was just a coincidence.

  1. It could happen due to your copter size and mass. It depends what do you mean as “usual”. I unsure results for your copter may have same values or scale as results for 450-sized drone. More weight, more inertia moments, more power needed to start motion and to stop. It’s not just about motors and battery power.

  2. It could. Even a battery position or orientation change could lead to different values after autotune.

  3. I believe you need to set all ESCs to same min/max value. I believe 1500 vs 1525 vs 1488 it doesn’t matter for copter while have all ESCs configured in a same way.

  4. To be honest I have no idea on that. It looks like IMAX can be considered as a max value for autotuned rate of I.

  5. Compatible memory card list for pixhawk: https://pixhawk.org/peripherals/sdcards

  6. I believe that average temperature of motors could depend on PID settings. As soon as you get control more sharp and aggressive, it will apply more powerful impulses for attitude change or correction. It means temperature will grow also.

  7. So far I can see it starts autotune with current PID values, not with some default values: https://github.com/ArduPilot/ardupilot/blob/Copter-3.4/ArduCopter/control_autotune.cpp#L778-L781

  8. It could be pretty much ok due to air temperature and atmospheric pressure changes. Everything it could rely on to calculate barometric altitude is atmospheric pressure. Then value could be fixed with correction from GPS.

  9. I never used auto analysis, so unable to say anything here. Sorry.

  10. Unsure GPS is able to provide orientation data. AFAIK the GPS is about position, not orientation. Also typical drone GPS module have 5-10Hz data refresh rate that seems not enough for any stabilization tasks.

  11. LMGIFY :slight_smile: No idea, really. But now I get curious and going to google. Thanks for pointing.

  12. Not me so far :slight_smile: You may ask this question here: Pixhawk 2 Getting Started

regards,
Dmitry

Woow Dimitry…that is The Answer…thank you…i will try to explain

  1. It happened to me,and more than once to others…i remember Randy answered to someone that is maybe only mission planer issue,nothing to learn there…but thx for links and connections…

  2. for normal value i ment similar values i had before(this is not new copter,but in his 3rd reincarnation) and values Randy suggested…i am talking about values of 1,6 instead 0,16…

  3. I didn’t mean position and COG but values of current/voltage…hmm…my english is poor

  4. hm…i will have to study this more…now i remember how i was against Robert Lefebvre when he critisize BLHeli and SimonK,but now i have to humble agree that this add more complexity in already complicated thing…

  5. My wondering is about PID translations,something must go wrong here…

  6. thx,mine is on the list…

  7. I know that,of course,also motor timing…my wonder was bcs.Autotune is also aggressive (mine is at 0,91 20Hz) and next day with moderate PID 5 min calm flight hot…Sabilize Roll and Pitch was a bit high…

  8. Ok…i guess i knew that bcs in past i made few autotune in a row…what about parameter AUTOTUNE_MIN_D?

  9. Hm…and hm…

  10. me neither… :slight_smile:

  11. You have to study more how DJI gimbals work and why are they so successful,from small to big ones…also check why Movi freefly uses GPS on gimbal…also check Gremsy H3,H7,H16 users why they pay extra 150$ for CanLink connection between gimbal and AP…this are the best…it has to do something with position between aircraft and gimbal…HORIZON DRIFT is keyword…my english is to poor to explain well,sorry…

DRIFT FREE HORIZON

The control algorithms developed for the MōVI stabilizer utilize a very high accuracy GPS. This GPS allows for acceleration correction when the gimbal is used outdoors and has a GPS signal. This feature is useful when used on cars and helicopters where sustained extreme accelerational forces can cause non-GPS aided systems to drift.

  1. He was always great help…also i liked Marco Robustini and his great demos and bright observations…

  2. I wasn’t aware of that…sometimes i wonder how many people knows this forum exist and they can find answers here…for sure it is much,much better organized than last one…

Hello Emin,

First of all let me say that we appreciate your testing, it is important to test frames that aren’t the most used. I understand your frustration but, because you use a more unusual frame type, there is even less people with the knowledge to answer your questions. On the other hand, I have to say that you are trying too hard: frequently writing long posts with more and more questions and constantly editing those same posts makes it very hard for anyone with short time to give you an answer (I had to read your last post 3 times since you edited it 8 times in two hours).
You asked how much money you would need to give to get answers. Let me answer with this: OpenHub estimates the code in ArduPilot to cost $2.405.233 and that’s without any support. We would love to have the money to hire resources so that questions don’t go unanswered in the forum, but we just don’t. Hopefully this community can grow, people can learn with each other and support from developers can be minimal.

Now, let me answer some of your questions (as I don’t have answers for all of them):

  1. We have heard of this, but without any crash so we believe that it is a bug in Mission Planner. If you have a dataflash log with the respective tlog it can be helpful.

  2. Windows 10 shouldn’t have nothing to do with your problems. Regarding the memory card, faster and bigger is better. If I’m not mistaken class 10 is enough, 4GB can be fine, but it depends on how much logs you want to keep and how much information you log in each of them. In any way, the SD card shouldn’t have any connection with the way your vehicle flies.

  3. Baros drift with time, this a known issue. GPS is usually not used for altitude as it can be even more unreliable.

  4. Questions about Mission Planner should be posted in the appropriate category, I can’t answer it.

  5. I’m not following what you are asking here, can you explain your question better?

  6. Working. He is listed in our commercial support list (http://www.ardupilot.org/ardupilot/docs/common-commercial-support.html) so you may contact him for paid support.

  7. As with all hardware, any issue should be taken to the store where you bought it, and in last case, to the manufacturer. If the issue is regarding software, namely ArduPilot, you should post on this forum.

I will try to get answers to your other questions but I can’t promise that I will have answers fast.

2 Likes

Thank you Francisco

You are absolutely right about my posts…

I must apologize to everybody for that multiple editing…i will really try harder not to repeat that…
Part of that is due to my inexperience with posting in this type of forums…so when i get some answer or comment i rush to respond back…and,than later i remember something else…i believe english word for this is half-cocked (that does not sound good when i try to translate to myself :slight_smile:)…also my english is not good enough so when i review my text i see multiple mistakes…
I will try to concentrate more…

About answers…

  1. OK
  2. ?
  3. ?
  4. i will have to study that issue more…?
  5. ?
  6. OK
  7. hm…?
  8. OK
  9. OK
  10. OK
  11. Its not that easy to explain that,and for sure it deserves own blog…i will try to find some links to discussions
  12. Ahaaaaa…Great link,thank you,i wasn’t aware of that…only thing i am not sure if i am commercial…
    Also I am aware of how ridiculous and out of place my message about the payment was…its out of my league at the moment,i meant more like support…
    13.OK

So…we have 2.3.4.5…unanswered
i feel much better now…thank you all

  1. No idea, sorry.
  2. Yes, it could.
  3. Unsure I can get your question.
  4. No idea, sorry.
  5. Thank you for pointing that.

regards,
Dmitry

@ Dmitry
3. Eh i know that too,but cant figure how and why…
5. When i was reviewing my settings and also after uploading new software to my X8 i noticed my Y6 Throttle Accel IMAX is 5,where X8 have that parameter at 80,and others have some 2 figure number too…In this adventure(at beginning of this blog) i had problems bcs they did some PID translations to new values and on some frames was small mistakes and wrong translations…it’s connected with number 2 as well,and that is also reason why i asked question about tablet,maybe he put comma in wrong place,or communication with craft was not ok(no trace of that)

Wow,
This is a long thread. I was hoping to go through it tonight but I will have to wait until the weekend.

I am sorry for the delay!

1 Like

Thank You…
No problem,now when i got your attention i can wait as long as it takes…

Wooohooo,
I read through this start to finish. I will answer some questions quickly.

First up MOT_HOVER_ LEARN. For this to learn your new hover throttle the copter has to be in a hover for 10 to 20 seconds. If the copter is moving up and down it won’t update the hover throttle setting. So if you take off after changing the load for the first time and switch into Alt_Hold you will probably need to recenter your throttle stick to stop the copter climbing. Also if your Accel I max is very small you will find your copter will sink (I think you have solved this problem already).

Just set your Accel I max to a big number, it only really matters if it is too small. This is something we will clean up in the next release.

Ok, the next issue is MOT_THST_EXPO. This is similar to what you are used to seeing with stick expo but designed to linearise the thrust of the esc/motor/prop to the pwm input. The effect of this is the output to the esc’s increase quickly at low ranges and slowly in the high ranges. So on an over powered copter the hover throttle will look very low. This is something you need to set based on thrust measurements but I have found 0.65 is a good number for most copters including all coax setups and 0.75 is good for very large props on quad hex and octo air frames.

A word on parameter translations and variables in mission planner Extended tuning screens. Some numbers have been scaled in mission planner in that screen. I always use the direct parameter screen so I am not sure which ones are scaled. As we clean up the parameters and move to SI units this should all disappear.

Alt Hold. I have found on over powered copters Alt Hold can benefit from halving the Accel P and I values and both the Pos and Vel Z values.

Hot Motors: When your tune is aggressive your motors will heat up more. This is especially true when using ESC breaking. From one flight to another you may find rougher wind results in higher temperatures. If your batteries are on loose and you start getting some slight oscillation your temperatures will go up.

ESC Calibration: a difference of 4 not a big difference. If you did it using the manual calibration that is probably as close to correct as you can get it.

Ok, Autotune.

Autotune always starts from your current PIDs. It does not start from a default set. If autotune takes a long time it is often because you are tuning in poor conditions or have made a change that results in a very different tune.

Copter leaning to one side more than the other. This is caused by an offset CG (not your problem), side ways movement through the air or side wind (more likely your problem), different ESC setups on different arms (probably not your problem).

The way I ensure I don’t have wind loading effects messing up my autotune is to always place the axis being tune 90 degrees to the wind. So I let the copter drift while it is tuning. When I decide I have to bring it back I only use yaw and the axis I am not tuning. So while tuning roll, I would yaw the copter so it is facing directly away from me and use pitch to bring it back. While tuning pitch I will use yaw to put the copter directly side on to me and use roll to bring it back.

Tuning in rough air or having wind effected tunes can result in very significant variations in Autotune. This is probably why your autotune numbers vary so much.

Ok, I think I have covered most of the outstanding questions. If you would like some help with your autotune results then let me know exactly what logs to look at and what issues you are seeing. I know you have had many autotunes in this thread but you have also changed many things and fixed many problems so I am not sure where you are up to.

Hope this has been helpful!!

3 Likes

HELLO EVERBODY

@Leonardthall
Thank you very much for time and answers…maybe we can come back for a few latter.
Yeah its long thread…sometimes is good as reminder when i did what…
I guess most of my questions and doubts are answered…
I didn’t answer before bcs. i wanted fresh results ,so today i made…You guess what?
Another…MFAT…in fact two of them!

Autotune 01.11.16

FINALY RESULTS OF AUTOTUNE ARE MUCH BETTER


Today it was a nice day,so i decided to give AT another try…
Considering advices about my setup i changed antivibration mount completely,and remove all suspicious parts
Here are pictures:


Uploading…
also i set
Throttle Accel I MAX to 80
THROTTLE ACCEL P:0,50 I:1,00

MOT_THST_EXPO 0.65
MOT_HOVER_ LEARN 2
AUTOTUNE_AGGR 0,08
AUTOTUNE_MIN_D 0,003

ATC_RAT_RLL_FILT 10Hz
ATC_RAT_PIT_FILT 10Hz

ATCRAT_RLL_P = 0,120375
ATCRAT_RLL_I = 0,120375
ATCRAT_RLL_D = 0,0050528

ATCRAT_PIT_P = 0,1645769
ATCRAT_PIT_I = 0,1645769
ATCRAT_PIT_D = 0,007028

At first when i try to invoke autotune,after entering alt hold followed by AT switch on ch.7 nothing happened…?
After landing and disarm/arm >>>AT started…Roll first…everything seems fine…
After landing and saving new parameters i thought i changed AT to Pitch tuning,but i didn’t press write button so Roll tune started again…that was fortune bcs in that SECOND tune,copter was autotunig somehow more crisp and did exactly all the steps properly,immediately i could noticed difference…
Afterwards i started Pitch tune…it looked ok,but after first try i ended with some unrealistic values of
ATCRAT_PIT_P and ATCRAT_PIT_I of 0,76
Only after second attempt of Pitch autotune right after,it tuned well

Here are the new PIDS

I AM VERY SATISFIED WITH TODAY’S RESULTS…THIS IS SOMETHING TO BUILD ON
My LiPos were empty,so i will do test flight another day,but it looks promising…
7kg Y6 is crisp and agile again…

P.S.Few times i’ve heard msg;inconsistent compasses …Compass learn was ON

Please share your warnings,thoughts,ideas and suggestions how to make it better…Thank you

My motors are medium hot again…when i test lower PIDs afterwards will try with BLHeli ESC timing medium-low settings instead medium…

when i look to my results from complete AT of 17.09.16 there is similarities,not much diference

Tomorrow i will start with PIDs 15% lower from today’s high results

That’s it…15% lower from AutoTune is somehow how i want it,crisp and responsive,but humble…
Loiter is perfect but AltHold still lose height at the end of fast forward flight if throttle is not added…
log from short test between rain;

DATAFLASH LOG 03.11.16

what do you think,is it too high?

Hi Emin,

The problem with your alt hold is the classic baro error caused by air moving over the aircraft and causing the pressure reading to drop. This results in the baro reading 1.5m higher than the predicted altitude. This causes the drop in altitude over the next few seconds.

I don’t have a fix for this without a lidar or better aerodynamic design of the static port.

another flight from today. 09.11.16…3.4.2 rc2…
alt hold correcting P as well…i dont know what i was soposed to see…?

I solved altitude lose covering the FC with a bowl