Heading Jumping by 90 degrees after turning

Hey there,
I´m using a CUAV V5+ along with a Neo V2 GNSS running Arduplane 4.0.4 in a big VTOL testbed-prototype.
The hardware came out of a previous first prototype where it worked perfectly. I´ve restinstalled this new hardware into the new prototype and left the firmware/parameters untouched exept adjustung servo limits and went to my flying field.

I noticed that my heading was wrong and offset but the curious thing was that I could turn the plane for example clockwise by 90 degrees and would see the red plane icon in mission planner spin in the same direction and amount, albeit with the offset. After a second or two though, the icon instantly snapped back the 90 degrees that it just smoothly turned.
I tried calibrating the compass on the field but it always failed. (green bar up to 100%, then resetting to 0%)

Back home it dawned on me that I had big speaker fairly closely placed to the Compass and that it could influence it, so I removed it. Still not able to finish calibration. Iv´e altered the placement of the compass as far away from any ESC, cables or metal in general but still can´t get the calibration to finish. I´ve also removed the batteries and tried calibration via USB to eliminate any potential electric fields due to currents but still no success.

At this point I´m out of ideas what else to try.
Do you have any suggestions?

Best regards

When you moved the flight controller to the new airframe did you re-do the calibrations? Might be worth it just to account for any differences between the old and new airframes.

Also, you may wish to try the larger aircraft compass calibration option if the plane is too big or too impractical to swing around. Compass Calibration — Plane documentation

I haven´t redone te calibration when moving to the new airframe but this is exaclty what I´m trying to do.
Onboard Mag calibration always fails, the green bar goes up to 100% then a failing beeping sind from the FC and the bar resets to 0. I use this procedure to calibrate: Pixhawk Onboard Compass Calibration - Arduplane - Mission Planner - YouTube

Live Calibration “works” in the sense that I can see the points beeing generatet around all the different axis when I rotate the Vtol. It finishes and says that its saving the new offsets. Yet still, the heading is wront and the error with the jumping heading persists. Sometimes I also get the “error compass variance”.
The external compass is the only one activated. I´ve also tried activating the 2nd compass that is integrated into the CUAV v5+ flight controller. This calibration completes nicely without problems. When setting this internal compass up as the primary compass and disable the other the heading is correct and the error with the jumping heading vanishes as well.

Is it possible to permantly damage/destroy the compass modules has been close to a magnet?

Thanks for your help

If you try Large aircraft compass calibration you shouldn’t need to swing things around like that. It’s not perfect but it’s enough to get you flying and then compass learn can sort out the details in the air.

If your getting the compass variance error then the IMU is sensing movement that doesn’t agree with the compass direction (or vice versa). Something could be loose. Or if you have power leads/ESCs near the compass that will mess things up.

I don’t know about long term damage from a big speaker. I doubt it, but. I’ve been wrong before…