HdZero VTX & Ardupilot OSD

Hi!

At the moment, the onboard OSD in the boards like Matek are compatible with the new digital system HdZero?

I think at the moment only its compatible with betaflight.

anyone have more information about this?

we going to make a drone with arducopter, matek and digital video, we asume lost the osd at the moment

1 Like

Yes, i’m use this settings:

OSD_TYPE = 5
SERIAL5_PROTOCOL = 42
MSP_OPTION = 5

But, stick commands for OSD menu are not functional at moment. I use the keypad for configuration.

2 Likes

Thank you very much.

works perfect!

its awesome ardupilot osd with digital video system!

1 Like

Hello,

I can’t get the osd to show up on my hdzero system,
I am wondering if I missed anything obvious.

HW Setup:
fc: holybro Kakute H7 with fw ArduCopter rev 4.3.2
vtx: hdzero freestyle with fw 22-12-2022
vrx: hdzero rx4_4sma with fw 22-12-2022

HW wiring:
vtx rx,tx connected to fc t1,r1
vtx sa connected to fc t3
vtx power/ground from fc Bec

Arducopter Settings
SERIAL1_PROTOCOL = 42
OSD_TYPE = 5
MSP_OPTION = 5

Video is excellent! but I can’t see the fc osd info.
Only the goggle side info.

Read most of the forum, tried a lot of things but no osd.
So I would like to ask If I missed something obvious…

Any help much appreciated!

Boris

Please check if TX/RX from VTX is connected correctly and set SERIAL1_BAUD = 115

Hello Reinhard,

I tried to do just that, RX/TX is wired ok, serial1_baud = 115. Still no OSD.

All I can think of now is trying a different uart, or flashing to betaflight to check if hardware is ok.

If there are more options, pls let me know.

Many thanks for the help.

Boris

Hi Boris,

if TX/RX is really connected crosswise as you have documented above, it must work with these settings.

Possibly it is worth to connect the TX/T1 and RX/R1 as a test, if perhaps the board designations are interchanged.

Also look in the setup of the VRX or there the OSD is activated.

You could also flash Arduplane as a test, that’s what I’m running this with. No idea if it is available in Arducopter.

Hi Reinhard,

Thanks for the help! I got it working now…
Short summary below in case it helps someone else.

Tried as suggested, and interchanged the TX/T1 and Rx/R1, did not work either, but it made me look really hard at the pinouts and connections and I think that did reveal something odd.

In the version of the HD-Zero manual I am using ( v0.5, the at the moment current one from the hd zero website ) there is a table with the pinouts for the freestyle vtx on page 10. I think there is something wrong with that table.

It lists from top to bottom “ground power rx tx sa”. However the supplied cable uses colors “red black yellow green blue”, which is inconsistent with the table, and I was powering the vtx with red wired to v_bec and black to gnd and it works in the sense that it transmits good video.

Went to watch some installation video’s where they use the ‘logical’ sequence suggested by the cable colors… which makes me I think both ground and power and rx tx are swapped in that table.

This did not solve my problem because I tested it already with your suggested test, but I went ahead and soldered the newly assumed tx (yellow) to R4 and assumed rx (green) to T4. Changed Serial1_protocol to -1 and Serial4_protocol to 42, Serial4_baud to 115, other osd related settings as described in the previous messages. Powered up and this works! very pretty lettering on the screen :slight_smile:

In summary, I have no idea why T1/R1 do not work on my fc, but if I connect rx/tx in the right order to R4/T4 + suggested serial settings the osd works fine.

Anyways, hope this helps someone & thanks for the support!
I’m off to the field, there is no wind and the sun is out.

Boris

The table in the manual for the Freestyle VTX does not describe the sequence, but only the cable colors with which function. At least that’s how I understood, connected and just worked right away.

If it works now it is great. Enjoy the HD flights … :smiley:

Flights were great! Definitely an upgrade wrt analog.

Strange that in this case my work experience worked against troubleshooting this.
I am used to never trust wire markings or colors, but to go from rail / connector / socket order or numbers. But I guess sometimes things work differently, different assumptions to start with…

But problem solved, works great, thanks for the help!

Boris

it’s been a while now, is there a progress for the stick commands for OSD Menu?

Hello Lui,

I have stick commands partially working.

I can enter the osd menu by using the normal stick commands with the pitch channel inverted.
Which is sort of counter intuitive, but it works ok.

I have been unable to get to the camera settings using stick commands so far.
And it is not a real issue for me, the camera image is excellent…

I am running copter version 4.3.6 at the moment.
hdzero firmware I have to look up, could be quite old.

Hope this helps a bit,
Boris

Thanks Boris, good to hear…actually I just need to change the power to pitmode or lower the power to prevent from over heating while waiting for GPS fix… OSD im okay and happy with it…

but let me try that inverting the pitch… thanks for the inputs.