Having Trouble running the sim on ArchLinux

Greetings! This is my first post here and unfortunately it is because I am having trouble with the ArduCopter Simulator.

I am running Arch Linux and I’ve been trying to get the SITL ArduCopter simulator working on this system.
I have been following this DroneAPI guide from dronekit.io which also links to this SITL guide from dev.ardupilot.com. Both of these guides are written for Debian based linux systems and hence only provide Debian package names when listing dependencies. I have done my best to hunt down each of the dependencies and install the Arch equivalent.

I run into issues when i execute the simulator via sim_vehicle.sh. It appears that several modules are not loading properly when the script is run. What i find odd however is the doesn’t appear to be any “fatal” errors that kill the simulator, but rather the program arrives at the terminal input and simply does nothing. Here is a link to pastebin with my terminal output.

In addition to this, there are two xTerm windows that are opened each time the simulator is launched. One is titled “Simulator”. It’s output is linked Here.
The other is titled “ardupilot”. It’s output is linked Here.

Thank you in advance for reading my post, I look forward to any help and advice you can offer.

I recently switched over to Arch and was wondering if you have had any luck with this?
Mine seems to be an issue with python2 vs python3
I tried to use a virtualenv which seemed to work up until this point

[665/665] Linking build/sitl/bin/arducopter-quad
Waf: Leaving directory `/home/jesse/gitrepos/ardupilot/build/sitl'

Build directory: /home/jesse/gitrepos/ardupilot/build/sitl
Target               Text     Data  BSS    Total  
bin/arducopter-quad  1246474  1888  35264  1283626

Build commands will be stored in build/sitl/compile_commands.json
'build' finished successfully (3m41.219s)
SIM_VEHICLE: Using defaults from (/home/jesse/gitrepos/ardupilot/Tools/autotest/default_params/copter.parm)
SIM_VEHICLE: Run ArduCopter
SIM_VEHICLE: "/home/jesse/gitrepos/ardupilot/Tools/autotest/run_in_terminal_window.sh" "ArduCopter" "/home/jesse/gitrepos/ardupilot/build/sitl/bin/arducopter-quad" "-S" "-I0" "--home" "-35.363261,149.165230,584,353" "--model" "+" "--speedup" "1" "--defaults" "/home/jesse/gitrepos/ardupilot/Tools/autotest/default_params/copter.parm"
SIM_VEHICLE: "mavproxy.py" "--master" "tcp:" "--sitl" "" "--out" "" "--out" ""
RiTW: Starting ArduCopter : /home/jesse/gitrepos/ardupilot/build/sitl/bin/arducopter-quad -S -I0 --home -35.363261,149.165230,584,353 --model + --speedup 1 --defaults /home/jesse/gitrepos/ardupilot/Tools/autotest/default_params/copter.parm
which: no osascript in (/home/jesse/OneEngineering/env/bin:/home/jesse/gitrepos/jsbsim/src:/home/jesse/gitrepos/ardupilot/Tools/autotest/:/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl)
  File "/usr/bin/mavproxy.py", line 942
    print "MAVProxy is a modular ground station using the mavlink protocol"
SyntaxError: Missing parentheses in call to 'print'
SIM_VEHICLE: MAVProxy exitted
SIM_VEHICLE: Killing tasks

Nevermind I got it now,
it did work with the virtual env
I didn’t have pip2 so I was installing things to the python3 directories