Servers by jDrones

Having trouble connecting to mp over anything other than .com port

I can connect MP to a com port ok .
However I’m trying to connect to crossfire WiFi module which has been activated and brought to latest (2.02) firmware . I have same trouble connecting to rfd900 TxMOD WiFi module so this is not isolated to crossfire unit .
My PC or laptop have no trouble connecting to the WiFi module .I also have no trouble getting to WiFi web page 192.168.4.1

What I can’t do is connect MP to the WiFi module . I have no idea what is meant by TCP or UDP or port numbers . When MP asks for this info when trying to connect by TCP I don’t know how to answer those questions . The error I get says “host refused connection” .
Any help on where can find this info would help me solve this problem which has gone on for many months .
Any attempt to connect by “auto” only results in locked up MP

did you tried to read the docs ?


Page 19

Yes I’ve read those docs . The issues with the rfd TxMOD are worse than with crossfire .
The crossfire TxMOD works perfectly as far as RC commands getting to rx and telemetry coming back from rx .

What I’m trying to do is pass telemetry out to MP thru ground station laptop via WiFi .as far as Bluetooth , forget it ……way to slow and sporadic connection.

Of all the ardupilot problems I’ve had …very steep learning curve …… this WiFi thing I just can’t get thru .

I believe the entire problem rests with how to connect to MP by TCP or UDP .
MP keeps refusing requests to connect ( or maybe it’s the WiFi module that’s refusing since I’m trying to initiate thru MP )

Damm , so much time spent on this computer stuff . I’ve probably forgotten how to fly by now . I’ll finally get it working some day only to crash !

You need to set both MP and the TX module to the same protocol. TCP is a connection based, client - server protocol. The TX module would be the server and MP the client connecting to it. So you would select TCP in MP, click connect, enter the TX modules IP address and the port you configured the module to and MP should receive mavlink telemetry.
UDP is connectionless and in my opinion better suited for UAV telemetry. The TX module would send out the mavlink telemetry to the MP/GCS computers IP address on a port you configured (default is port 14550 in MP). MP should pick up any telemetry stream coming in on that port, without the need to click on connect.

I dont know what you mean by “the port you configured the module to” ?
I dont understand ANY of this networking stuff . To me a port is something a ship sails into .
Anyway I tried UDP with port 14550
it didnt work , see response I got in image
so much for the image , the file is too large it says .Cant even upload a single picture !!!

This is the first sentence of what the error says in MP connect attempt
“only one usage of each socket is normally permitted”

I do not have first hand experience with the RFD900 TXmod, but it should have a webinterface where all configuration can be done.
The manual states the TX module is always configured for both TCP (port 23) and UDP (port 14550) connections. Since there is no target IP address entry for UDP, it most likely broadcasts the telemetry stream to all connected devices.
You can always shrink pictures or upload them to a filehoster/clouddrive and post the link.
The error message occurs, because Missionplanner is already listening for incoming telemetry on UDP port 14550, so when you click connect and try to use port 14550 a second time, this error pops up.
Since you said you are trying a crossfire setup, too, I tried it with my crossfire TX/RX. I updated to Wifi 2.02 and firmware 6.0x (can not remember the number right now).
CRSF TX/RX protocol gives me telemetry on my Radiomaster TX16S, but receiving mavlink telemetry with Missionplanner fails. I tried setting the wifi to different ports, but nothing.
I then tried to set the Nano RX to Mavlink TX/RX as I used it before ardurover 4.1, but no matter what I tried, no telemetry and no RC input.
I used the telemetry forwarding before, as well as mavlink RC control.
I suspect there is something wrong with the firmware, but I did not have time to downgrade.

For the hell of it I loaded QGroundControl onto my iPad . QGroundControl uses UDP and port 8888 .

It connects no problem !
The issue is with the laptop and windows 7 setup .
I can try UDP and port 8888 on laptop and it doesn’t work .

Some utilities for debugging network connections:

  • ping
  • ipscan
  • ifconfig/ipconfig/ip
  • browser (ESP8266’s)
  • LiveTcpUdpWatch (Windows)
  • Wireshark
  • Nmap/Zmap
Servers by jDrones