Have Pixracer R14 but still can't get it to bind w/ DSMX

I have recently purchased a pixracer for a medium sized quad from mRobotics and I can’t get it to put a receiver into bind mode through mission planner or Qgroundcontrol. I know that the first rev pixracer had a hardware issue that prevented the use of spectrum satellite receivers and that there was a hardware fix that would let you use them but wouldn’t let you put them in bind mode but from what I can see that all was fixed with the R14 board which is what I have. Is it possible I got a bad autopilot?

I can bind the sat when connected to a normal dsmx receiver and everything works normally when it’s bound.
The board is actually an R14 board as it says “RC14” next to the sd card.
Tried reflashing firmware with both Mission Planner and Qgroundcontrol and it came with current firmware already loaded.
Receiver works properly once bound.

This is the receiver that I’m using and I’ve swapped it to make sure it’s not a problem with that.

EDIT: I flashed px4 and binding worked just fine so it’s a bug in APM