Harmonics Filter causing extreme oscillations

Nice my hover point is at lower but parameters won’t let me set it weird🤦🏾‍♂️

The Nanny ranges in Mission Planner?

Set the MOT_THST_HOVER value you want and hit Write. Answer yes to the “out of range do you want to continue”. Then hit Write again.

Yeah I did it 3x and refreshed and it went back to default 0.2

As I suggested hitting Write Parameters a 2nd time after hitting Yes to the out of range dialog box? Don’t refresh until you Write it the 2nd time or it will fail.

You can put whatever you like in there if you follow the correct sequence to Write it.

1 Like

I’ve noticed that mine likes 0.125. The logs clearly show 0.08 as an average hover thrust value, but I think hover learn has some limits. I can set 0.08 and save it (acknowledging the warning), but if I enable hover learning, it reverts to a higher value.

Yes, I have found that to be true also.

Is the hover thrust value skewed by the motor expo? I think that woks out pretty close then.

1 Like

I don’t think so?

It’s always EXACTLY 0.125. If hover learn weren’t bottoming out against some predetermined limit, I’d expect some minor variation (and more digits behind the decimal, as is usually the case).

EDIT: Yep - it’s constrained in the code.

ardupilot/AP_MotorsMulticopter.cpp has this call to constrain_float():

_throttle_hover.set(constrain_float(_throttle_hover + (dt / (dt + AP_MOTORS_THST_HOVER_TC)) * (get_throttle() - _throttle_hover), AP_MOTORS_THST_HOVER_MIN, AP_MOTORS_THST_HOVER_MAX));

ardupilot/AP_MotorsMulticopter.h defines the lower bound as 0.125.
#define AP_MOTORS_THST_HOVER_MIN 0.125f // minimum possible hover throttle

1 Like

I’ll redo the sequence

Yes I just found all that too and was going to mention it :slight_smile:
So apart from being constrained, MOT_THST_HOVER is also rounded, which is why we dont see a lot of decimal places.

1 Like

Good Afternoon ,

Change the parameters for the hover throttle and man it still only in AltHLD & PSHLD seems like its about to drop out the sky motors start slowing down immensely.



I would try 2 things. Your MOT_SPIN_MIN is at .15, lower it. Give it a flight, don’t bother with PosHold (it should be deprecated), use Loiter*. Then set these and try it again:

The reference for setting these parameters can be found here:

*You will find several Loiter parameters than can be set to your liking, PosHold has 2.

1 Like

Awesome I’ll adjust parameters. Shit freaks me out

You’re doing fine :grinning: Try .09 for MIN.
_ARM Minimum speed for all motors running cleanly in Motor Test.
_MIN >ARM and the minimum thrust to stabilize the craft when it’s dropping in Stabilize at zero throttle :wink:
At least that’s what I do.

I have a very high thrust/weight craft also (a few actually) and here are some relative parameters. Not to copy of course just as reference for the challenges encountered with rocket craft!

1 Like

Question is there a way to switch between parameters with a aux switch on RC? This craft or (rocket LOL) is specifically for Film and TV done some test flights with gimbal which cleaned up a good amount of vibrations but I can tell there is significant vibrations that occur in footage. Ill send video not the best camera its a Nikon test camera we use for gimbal stuff. I know when you tune it says not to do so with a gimbal or camera attached.





You can lower the ATC_ACCEL values to suit heavy payloads
or you can just lower them a bit anyway, to take some of the aerobatic like behaviour out of the copter.
Single digits and decimal places are not important, you can safely round these to the nearest thousand.
Do not change any of the other "PID"s.

You can also smooth out the RC input a bit. This used to be called RC Feel, and it still is in the tuning section.
Set ATC_INPUT_TC from 0.2 to 0.3 for a softer feel.
You can put it on a channel 6 tuning knob too, assign a pot to channel 6 on your radio and set:
Make sure nothing else is using channel 6 of course. Setting a non-zero value in TUNE automatically assumes you are using channel 6, and you dont have to configure channel 6 anywhere else in arducopter.

In that log the tuning is very locked in and working great!
Vibrations seemed reasonable, not a problem.

Here is one of the good things about spending time to get the tuning as good as possible - it’s now very easy to see if there’s any problems creeping in that need attention.

Your right when I looked at log everything was great. So Tow so I’m not over thinking is the weight of the payload correct??

Yes Take Off Weight of the whole aircraft, combined with payload.
Minimum TOW and Maximum TOW

A buddy of mine flew a movi pro under his FPV heavier payload per directors request and said his went bonkers. Trying to get him to go to Arducopter it just makes sense. Hence I’m in the same position no payload is the same for each shoot.

This is just getting better and better that is astonishing that you can adjust this prior to a project.