Harmonic Notch filter don't see peak

I can’t find a peak in that log file.
In that flight drone was about to crash to a wall. So pilot did a little move. Is that log okay to use for managing notch filter?

The link has an Access requirement.

ah sorry. I updated it.

Because you are using Log scaling. This is what you have:

I would make another Hover flight with no sudden moves.

1 Like

@dkemxr if it is related that in params INS_HNTCH=0 in this case.
It must be enabled and then configured as i learnt from you and other devs.

It’s not related. He’s at the initial data collection stage logging pre-filter data. It doesn’t much matter if the notch is enabled or not. All that’s important is the INS_LOG_BAT_MASK be set to 1 at this point. The data that was logged would be fine if there wasn’t the sudden move during the hover flight he reported.

Today I retried that and I get this log.
Then I set harmonic notch with 102 hz peak frequency.
After setting INS_LOG_BAT_OPT to 2 I get that log.
So it works (I guess). Know should I also configure INS_HNTC2? If yes, what is the new peak frequency?
Last flight with INS_LOG_BAT_OPT=0: https://drive.google.com/file/d/1ZMIab1GBGOoVV26GlnmiweE3iUr4ar2j/view?usp=sharing

Looks good and no, you don’t need another notch.

1 Like