Half control surfaces don't work with XPlane 12 and MP SITL

I am trying to get SITL to work with XPlane 12. So far everything connects just fine, but when I try to fly in XPlane only half the control surfaces work. The left elevator and aileron will move, but not the right. If I disconnect SITL and restart XPlane, it works fine, but once I reconnect SITL suddenly the right elevator and aileron no longer respond to control inputs.
I’ve tried this on two different computers with different joysticks with the same results. (actual joysticks, not rc transmitters)
I did notice that if I change the Network Output port number in XPlane to anything other than 49001, none of the controls will work except the throttle.

Here’s a picture to show what I mean:

Which version of the Arduplane do you use?

I’m assuming it’s the latest one, 4.4.0. Whenever I load the SITL from the Simulation tab on Mission Planner, I select Model: xplane >> Plane >> Select you version: Stable

my Mission Planner version is 1.3.80

Quick update: I think I was using arduplane 4.3.8 before. I just tried again using 4.4.0 (and 4.5.0-dev) and this time all the controls on the aircraft in Xplane were locked up at max deflection.

I have same problem with the Arduplane V4.4.0.
In my case all control surfases are set to the extream positions when Xplane and MP are connected.
There was no such a strange behavior when I used the ArduPlane V4.3.8 so I believe this is a bug with the V4.4.0.

Thanks for the info. I will try using older versions to see if that helps.

Apparently running SITL with older versions of Ardupilot is not as easy as it could be.
If anyone has a solution to this thread (the controls problem or SITL with older versions) please let me know.

Have you resolved the problem? I haven’t yet but I found one important phenomena.
When MissionPlanner is connected with Xplane the check mark of Xplane’s “8 Joystick aileron/elevator/rudder” in the “Network via UDP” column of the “Data Output” page is erased and can’t be checked again.
I believe because of this strange phenomena RC control inputs to Xplane can’t be tranfered to MissionPlanner. Please check it by youself.