Servers by jDrones

GUIDED_NOGPS mode gets FCU: No such mode

Hi, when trying to set the mode 20 or GUIDED_NOGPS using mavros mavsys, I’m getting FCU: No such mode. I first thought it was mavros but it seems that is actually sending the command because if I send something wrong it would say MODE: Known modes are: GUIDED_NOGPS AVOID_ADSB THROW BRAKE... and also other modes like 0 work fine. My FCU type and autopilot are being recognized correctly from mavros (it seems) but the FCU is not accepting the mode.

The command that I’m running is rosrun mavros mavsys mode -c GUIDED_NOGPS and I’m getting Timed out! and on the logs of mavros node getting FCU: No such mode I suspect it is Ardupilot but I want to start the discussion first to see if I’m probably doing something wrong.
Thanks.

Using:
ROS melodic
Mavros: 1.5.0
ArduCopter V4.0.6,
FCU: KakuteF7 00250031 35385109 38333932
ChibiOS: d4fce84e.

Any idea or any suggestions?

I also tested with QGroundControl and it is also not posible to set that mode.
I was investigating more and I thought it could be some firmware limits as stated here but the Guided mode is not mentioned as a limitation:

**KakuteF7, KakuteF7 Mini, OmnibusF7V2, Matek F405, Matek F405-Wing/ F405-SE,OmnibusF4/ F4Pro**

* SMBUS battery
* Parachute
* Sprayer

I also checked the ardupilot code and it depends on a MODE_GUIDED_NOGPS_ENABLED variable which might be disabled for my board KakuteF7. Is there a way I can see if it is enabled or not? I haven’t found the repo where the params are defined for each board.

Thanks

Has the problem been solved?

Servers by jDrones