Guided mode mount control not responding

We’re having a problem with the Solo’s guided mode mavlink mount targeting. Many of the smart shots use Mavlink MSG_MOUNT_CONTROL to aim the camera. It controls the yaw and gimbal pitch. For reasons unknown, this is not working. The copter does not respond at all. No change to yaw or gimbal pitch. I tried changing it to use MAV_CMD_DO_MOUNT_CONTROL and that doesn’t seem to work either. But I’m not 100% confident I did it right either.

Is there way to see in the dataflash log what guided mode commands are actually being received? I uploaded a log to here

Existing mavlink command is this, where newPitch and newYaw are the degrees
pointingMsg = self.vehicle.message_factory.mount_control_encode( 0, 1, # target system, target component newPitch * 100, # pitch (centidegrees) 0.0, # roll (centidegrees) newYaw * 100, # yaw (centidegrees) 0 # save position)

I also tried this, without the centidegrees.
pointingMsg = self.vehicle.message_factory.command_long_encode( 0, 1, # target system, target component mavutil.mavlink.MAV_CMD_DO_MOUNT_CONTROL, # command 0, # confirmation newPitch, # pitch (degrees) 0.0, # roll (degrees) newYaw, # yaw (degrees) 0, 0, 0, # params 4-6 (unused) 2 # MAV_MOUNT_MODE_MAVLINK_TARGETING)

I’ve had a quick look and I don’t see any fundamental reason why it wouldn’t work. It looks to me like we accept the COMMAND_LONG with the MAV_CMD_MOUNT_CONTROL in it and the deprecated MOUNT_CONTROL message.

I guess something is going wrong but it’s not super obvious to me.

Is there any way to see within the dataflash log how guided mode commands are being received or handled? I’m trying to determine if the commands are being sent properly and not executed by AP, or if the commands are not being sent properly from the companion computer.