Guided mode auto take off insane spinning!

i have a quadcopter, apm 2.8 with external compass (copter 3.2.1).
f450 frame and 920KV motors.
so a few days ago i had a problem with compass calibration and ended up crashing!
when i checked the logs i found this error : EKF CHECK-2
i fixed the compass and tested the copter and it was flying pretty good!
i tried altHold and Loiter and didn’t noticed any problems.
then Tested Land mode and it was all fine. it landed as expected.
but when i tried to perform an auto takeoff in guided mode using mission planner,
right after takeoff it started spinning insanely!!!
Only in guided mode and right at the beginning of the takeoff…
so i landed the copter and tried other modes and all of them were fine!
after that i came home and checked the logs, there are no errors!
i really can’t think of an idea why the copter does that only in guided mode!
an i should mention that the drone had no problems with guided mode before.

So i think i fixed it!
one of the [motor --> Esc] wires was loose, i fixed that then tried guided mode auto take off and it was flying well!
but why?
why only in guided mode? i can not find any explanation for it…
if it’s about one of the motors spinning slower then the others, why it only effected on guided mode?