Guided mode ARdurover v3.0.0

i’m trying to do a personal follow me project that is based on Guided mode. The main idea is that my rover will follow a target until i send a NEW MISSION (new target ID) so the rover will switch the target.

Im using :arduino, UBlox GPS and Xbee to send GPS coordinates as a target and im trying to use MavLink messages to write new addresses in Pixhawk. In Auto mode with this Gps values as WayPoint Rover work Fine (ArduRover 2.5) and Auto Mode don’t even work in 3.0.0 version. Today i tried Guided mode with Ardurover 2.5 and 3.0.0 and it doesn’t work at all.

Is there anyone who worked with the guided mode with a Rover.



PS: sorry for my NOOBS english

Guided and Auto mode work well in 3.x . Did you send ARM cmd to your rover ?

thanks for you’r fast reply.
Of course i Armed my rover and in MANUAL MODE work fine ,but in guided mode It does nothing.
Inauto mode i used it with ArduRover 2.5 and it works fine but when i switch it to ArduRover 3.0 rover become CRAZY and not going on the wp.

Hi marouen,
have you completed your follow me project?
I’m trying to do something similar.