Guide for Geofence [SOLVED]

Hello guys!

Anybody to guide me through setting up the geofence on arduplane 4.2.2 and mission planner

have you read this doc ?

Or this:

Yes, I’ve seen these posts and I have enabled and set up the fence parameters but on the plan tab when I draw a polygon and the right click the geo-fence option is gone.

The first two screenshots are when I have connected my Pixhawk 4 and you can see that I don’t have the geo-fence option. However, when I have nothing connected I have it. No geo-fence no fence inclusion exclusion options.

It appears you are getting things confused - As instructions state : " For firmware versions 4.1 and later, Plane uses the either a home centered Cylindrical Fence, see [Cylindrical Fence] and/or Inclusion/Exclusion Fences"

As you are using version 4.2.2 there isn’t any polygon fence anymore. - That’s why that option disappears when you connect your FC with version 4.2.2

You will have to follow the new instructions instead:

and / or:

Update: I guess the step that you are missing is the “Fence” option in the dropdown list up in the right hand side corner.(within planing screen) A popup window will appear explaining the new procedure.

1 Like

Thank you I’ve found it!

1 Like