Gstreamer pipeline for openHD in MissionPlanner?

I am unable to get videofeed in the HUD of Missionplanner., I use raspberry Pi with openHD connected with ethernet (or wifi) to PC with missonplanner.

In MP the videotestsrc works:
videotestsrc! videoconvert ! video/x-raw,format=BGRA ! appsink name=outsink

in CMD line with gstreamer I can “catch” the feed on port 5600
for raw setting openHD

  gst-launch-1.0 udpsrc port=5600 ! h264parse ! avdec_h264 ! autovideosink sync=false 

for rtp in openHD

 C:\gstreamer\1.0\msvc_x86_64\bin>gst-launch-1.0 -v udpsrc port=5600 caps="application/x-rtp, media=(string)video, clock-rate=(int)90000, encoding-name=(string)H264" ! rtph264depay ! avdec_h264 ! videoconvert ! autovideosink sync=false

or C:\ProgramData\Mission Planner\gstreamer\1.0\x86_64\bin>gst-launch-1.0 -v udpsrc port=5600 caps=“application/x-rtp, media=(string)video, clock-rate=(int)90000, encoding-name=(string)H264” ! rtph264depay ! avdec_h264 ! videoconvert ! autovideosink sync=false

How can I write gstreamer url for HUD in Mission Planner, Mission planner is not detecting automaticly?

thank you

ok try

udpsrc port=5600 ! h264parse ! avdec_h264 ! videoconvert ! video/x-raw,format=BGRA ! appsink name=outsink

or

udpsrc port=5600 caps=“application/x-rtp, media=(string)video, clock-rate=(int)90000, encoding-name=(string)H264” ! rtph264depay ! avdec_h264 ! videoconvert ! video/x-raw,format=BGRA ! appsink name=outsink

Hi Thanks

I already tried those with no success but because these have to be the sources i tried different combinations. can you check procedure how I got it working, it needs to be more automatic but I dont know why MP does not connect immediatly

on raw settings on port 5600 the stream udpsrc port=5600 ! h264parse ! avdec_h264 ! videoconvert ! video/x-raw,format=BGRA ! appsink name=outsink
works after strange workaround…

  1. start MP , nothing in HUD, even when press gstreamer source

  2. start gstreamer manually cmd.exe but nothing happens

    C:\gstreamer\1.0\msvc_x86_64\bin>gst-launch-1.0.exe udpsrc port=5600 ! h264parse ! avdec_h264 ! autovideosink sync=false
    

3.Nothing happens untill i close MP window, then gstreamer pops window with videofeed

4.restart MP and after udp connection is made , I close gstreamerwindow with feed

5.go to gstreamer source and press ok and voila stream is visual in HUD

If someone knows what and why … advice is welcome

thank you

BTW the rtp stream through port 5600 is not working this way… only stream on cmd.exe gstramer

Finally solved,

for those interested: after I knew the stream had correct pipeline, and was running after startup i deleted the config file ( ::: documents/missionplanner/config ).

After restarting MP I now press in videoHUD , stop gstreamer , then set gstreamer source (the one Mr Oborne gave in earlier post). the stream is running correctly

the fix you mention is because of this