Gstreamer - HUD

I have gstreamer working on my Raspberry pi and I am trying to overlay the video stream on my HUD screen in mission planner. The stream is arriving to my PC. I am having trouble to configure mission planner to show the stream. I have tried to add the source but it does not appear.
This is the gstreamer line: udpsrc port=9000 ! application/x-rtp,encoding-name=H264,payload=96 ! rtph264depay ! avdec_h264 ! video/x-raw, width=1280, height=720, framerate=30/1 ! videoconvert ! video/x-raw,format=BGRA ! appsink name=outsink
I have been following this article: How to setup a Mission Planner HD-Video HUD using GStreamer and Mission Planner plugins - Blogs - diydrones

Mission Planner version: 1.3.76
Gstreamer version: 1.18.5

I have tried the test URL with no joy: videotestsrc ! video/x-raw, width=1280, height=720,framerate=25/1 ! clockoverlay ! videoconvert ! video/x-raw,format=BGRA ! appsink name=outsink

I understand once I have set up the source the video should automatically overlay in the HUD. I receive no image or error message.

Can anyone please tell me what I am doing wrong?

Cheers, RS

Any help would be much appreciated.


I’m having trouble too. I can get the video to come into the HUD, but not automatically. Please see my other thread on the topic.