GSC FS Doesn't Engage

I’m currently using a Pixhawk with ArduCopter v3.1.5. For my ground station, I’m using an Android tablet with DroidPlanner. I also have a Spektrum transmitter for arming and manual control. My GPS/Mag is 3DR and my ground station telemetry link is 3DR 915 MHz. The problem I’m sunning into occurs when trying to test the GSC failsafe. My GPS and battery failsafes are working correctly. I have the throttle failsafe set to ‘Continue with Mission in Auto Mode’, and that seems to be working correctly. However, I have the GSC failsafe set to ‘Always RTL’ and whenever I try to test it but either disconnecting DroidPlanner or physically removing the antenna from the tablet, the FS does not initiate.

Has anyone else had issues with the GSC failsafe? Could this issue be because I have all other failsafes enabled? Thanks!

Although no one has posted a response, I thought I would update those of you that may be somewhat following this thread. From my troubleshooting, it seems like the throttle failsafe is active whenever I use the transmitter to arm and initiate the auto mode; however, if I use the GSC to arm and initiate auto mode, then the GSC failsafe works. I have not figured out a way to make the two work in conjunction. Does anyone know if they were designed to work separate from each other, or are they supposed to be able to work in conjunction. Thanks.

In order for the GCS_FAILSAFE to be triggered you have to to have been using the ground station to control the copter (i.e. using a joystick) and then lose Ground Control Station contact for at least 5 seconds.
Please see … n_Failsafe

also please see … let%20only

and Copter: known issues when flying only with Tablet

The GCS failsafe is intended to be used when there is no RC Tx being used but we have not finished implementing Tablet Only flying and the combination of Tablet (for control) and RC is not recommended.