Ground speed VS altitude in auto mode - Dangerous behaviour

Hi everybody,

I am optimizing the auto mode on my multicopters, for this I am trying different navigation speed.

During my last flight, I put the navigation speed to 20m/s and noticed that the ground speed takes the priority on the altitude.

This behaviour seems to me very dangerous because even with a very small navigation speed, in case of strong wind (lateral or front), the copter might loose its altitude and crash.
I imagine that it would be safer to have somehow the altitude as a more important parameter than the ground speed.

I didn’t read the code but I imagine the system acts like this because when it is travelling from a waypoint to another, the speed is a parameter for the current situation when the altitude is an objective that has to be reached at the next waypoint.
The only solution I found to avoid this is to put many waypoints so that if the ground speed is too high regarding the wind, the copter will go back to the requested altitude more often.

Is it possible somewhere in the full parameter list to flag the altitude with a bigger priority?
If not, is it planned to change this to avoid the situation I described and for which it would result to a crash?

Maybe the APM team is completely refactoring this matter and that would explain an other problem I have

The test was performed on a 3DR Y6 with Pixhawk

Thank you very much for any help

What firmware version?

If it’s a beta version I have noticed that it needs a bit more work (several known issues). I went back to 3.1.5 had have not noticed the problem you have.


Hi, thank you for your reply, I’ll check the version asap.

I don’t want to use a beta version but now I am wondering if the latest version proposer by mission planner is a stable version or a beta version.

Anyway I’ll check the version, perform another test where I load with “heavy stuffs” the Y6 if there is no wind and then post my results here.

You are posting in the 3.2 forum, so it is reasonable to assume that you are using 3.2 which is a beta version.


As for Mission Planner - it will offer what you select. If you select beta versions, you will get a warning and then be offered the beta version.

Hi StefanG,

I am sorry, I am almost sure I am in the latest stable version, I’ll confirm the version and I will reproduce the problem I experienced and then my post should be moved to the correct topic/version.

I can confirm that ALTITUDE is sacrificed for ground speed- not a good idea.

I flew with AC 3.1.5 at 2.8Km over Carpatian mountains and countless times the copter lost altitude due to lateral and frontal winds, just trying to mentain the GS.

Best regards,

I am also using V3.1.5, could please the moderator move this to the 3.1 topic?

Regarding dramida’s comment and my experience, is there any plan on modifying this and/or is there a way to tell the software to consider altitude as first priority?


As promised I made a new test, I loaded the Y6 with some heavy stuff and flew in auto mode asking for a ground speed of 20m/s and… It put the priority on the altitude!

It couldn’t reach 20m/s because of the load but it maintained the altitude

I don’t know why sometimes it works fine, sometimes it doesn’t…

I made some new tests at ground speed = 20m/s and every time, when there was a cross wind or front wind, the copter lost altitude, if I didn’t switch to loiter, it would have crashed.

My goal is to have a multicopter flying for ~15km missions over some semi desertic areas, in that case I might loose all the connections with the copter at some point so I won’t be able to switch to loiter and the flying altitude will be quite low.

Decreasing the ground speed not only would result in shorter missions but the lost of altitude can happen at any ground speed (lower is the ground speed, faster should be the wind to be a problem though)

Is this a know issue? Is this problem under review or correction?

Thank you for any help

Hi Guys

I have also noticed the same problem but only in altitude hold mode using manual control and pushing for high speeds. At some point (speed) it starts to lose altitude and will certainly crash if I don’t back down on the throttle.

I would like to test this problem in auto mode but I am having problems changing the speed. I would also love to be able to change the speed on command.

In Mission Planner under the ‘Actions’ Tab there is a Change Speed button with a text box before it displaying the number 100. Changing that number - even drastically- has no effect on my speed. The Do_change_speed command during waypoint navigation causes the drone to simply stop dead in the sky and won’t go to any waypoints or perform an RTL unless I land and restart the APM2.6 - disconnect/reconnect battery.

I have asked around on the forum regarding the speed control issue and no one knows.

So my question is - how do you guys change your speed? Can you do it without changing the default WPNAV_SPEED parameter? I am using firmware version 3.1.5 - APM 2.6 Y6


Hi Fjohnnyb,

To change the ground speed, all I found was also to change WPNAV_SPEED in the full parameter list


Hi Nevd

Thank you for the reply. I thought I was the only one. Can this be done while flying and during a mission?

I am not sure but since PID settings for stabilize roll, pitch and yaw can be changed during flight I suppose it is possible yes… One of us should try :wink:

If you look in extended settings, you can assign ch6 (normally a pot) to WP_SPEED. You can then turn the dial assigned to ch6 on your transmitter to min or max and this will influence the WPNAV_SPEED. At least I think that’s what happens. I use it to see how quickly my quad can get around assault courses without crashing :slight_smile:

Thank you for the tip :smiley:

fixed a while ago;

I’ll make new tests with the latest firmware but it doesn’t seem to be fixed.
Sometimes the copter looses its altitude and sometimes it doesn’t, it looks like the fix works intermittently.

Also I’ll try with spline waypoints and see if it helps.

Sorry for my previous comment, the fix is in 3.2 and I am still in 3.1, thank you for your answer Andre-K