Gremsy Zio does not work if set to Mount 2

Hello everyone.

I have been trying to set up two gimbals on my drone. One is a SIYI A8 mini and the other is a Gremsy Zio. I noticed that if I set the Gremsy Zio to Mount 1 it is recognized and works as expected but if I set it to Mount 2 I get “PreArm: Mount: not healthy” and “Camera: Gremsy.32 Zio Payload v2.32 fw:” messages. I am following all the setup procedures defined by gremsy documentation.

If anyone does know the reason behind this and could help I would be very thankfull.

1 Like

Hi @Andre_Freitas,

Thanks for the report. It’s very interesting that you’re attempting to connect two gimbals, you’re likely one of the first to attempt that.

The issue you’ve bumped into is here on the AP Gremsy wiki page. You’ll actually need to change the configuration of the Gremsy gimbal so that it sends as GIMBAL_COMPID2.

Please tell us how it goes. In particular as far as I know, nobody on the dev team has received a Zio so we haven’t been able to completely test the camera controls.

I am connecting two gimbals in order to test capabilities. It is not an extreme necessity.

Unfortunately I tried your sugestion but it does not work. :frowning:

If possible, I would recommend that the team invest some money in Gremsy gimbals for testing. They are a very good product in terms of hardware but the implementation with ardupilot is a pain. There is always something that does not work right unfortunately

Hi @Andre_Freitas,

Thanks again for the report. I can try and reproduce the problem, Gremsy has sent me a gimbal or two.

I’m afraid it really needs to be a two way street between AP and Gremsy. You’ll see our wiki has a load of warnings and hopes for fixes in future Gremsy releases.

1 Like

Hi @Andre_Freitas,

I setup a Gremsy PixyU gimbal as the second gimbal today and it seemed to work. Here’s some things I did

  1. Uploaded the gimbal to 7.7.3. When I originally tried with 7.7.2 which is what we recommend on our wiki the gimbal would not accept changing the component id to GIMBAL_COMPID2. With 7.7.3 I could set the component id
  2. MNT2_TYPE = 6 (Gremsy)
  4. SERIAL2_BAUD = 115
  5. RC6_OPTION = 216 (Mount2 Pitch)

I must admit it took me a few tries to get it working due to various silly mistakes with parameters. I found it helpful to ensure SERIAL2_OPTIONS = 0 (instead of the recommended 1024 to “not forward packets”) and then I used MP’s MAVlink inspector to ensure the gimbal was appearing.

This MAVLink inspector can be found on MP’s Setup Advanced page.

Just a random guess but I wonder if perhaps you were hoping to use MP’s Payload Control screen? If “yes” then this won’t work for now because it always tries to control the 1st gimbal… or perhaps the incorrect RCx_OPTION parameter was set?

Hi @rmackay9,

Thanks for you help.

Unfortunately I did all those steps with my Zio and it did not work. I tried it with firmware 7.7.8. Maybe that is the problem. I will try with a different firmware version and see if it works

1 Like

Hi @Andre_Freitas,

OK, thanks. I’ve ping’d Gremsy again but no promises of course.

I would be very interested in hearing if you can get the ZIO to work as the 1st mount (which is the more common case). Things to check include:

  1. RC rate control of roll, pitch and yaw. In this test, set MNT1_RC_RATE to 30 and confirm that the RC inputs for Mount1Roll, Mount1Pitch, Mount1Yaw can be used to slowly change the gimbal’s attitude
  2. RC angle control of roll, pitch and yaw. In this test, set MNT1_RC_RATE to 0 and confirm that the RC inputs for Mount1Roll, Mount1Pitch, Mount1Yaw can be used to directly control the gimbal’s angle.
  3. Yaw lock & follow test: In this test set an RC channel to “Mount Lock” and repeat the tests above. When the aux switch is pulled high and you pick up the vehicle + gimbal, the gimbal’s yaw should not rotate with the vehicle. With the aux switch low (e.g. follow), when you pickup the vehicle+gimbal the gimbal’s yaw should move with the vehicle
  4. Camera controls: setup auxiliary switches for “Camera Trigger”, “Camera Record Video”, “Camera Zoom”, “Camera Manual Focus” and “Camera Auto Focus” as described here on the wiki and ensure they all work.

Obviously this is a lot to ask so no pressure of course.