Gremsy MIO Action Cone


I am currently working on GPS pointing with a Gremsy MIO. I’m using ArduCopter 4.3.3 and latest MIO firmware version which is 7.7.2. I will attach a little video to explain the problem I’m facing.

The gimbal is configured according to the information available online on the Ardupilot website and Gremsy documentation. Mount type: Gremsy + Synchronous mode (in GTune). The main problem I have encountered is that there is an angle action cone that prevents from moving the gimbal between +/- 40 degrees in pitch and +/- 40 degrees in yaw. Outside of that, the gimbal moves correctly.

Video link:
gremsy_mio_1 1.MOV

Password: 1234

As you can see in the video, everything works correctly with the gimbal set at 45 degrees pitch and yaw. However, when yaw is changed to a range less than 40 degrees, the gimbal is zeroed directly on that axis. The pitch remains at -45 degrees.

Then, the pitch is changed to a range less than 45 degrees and the behavior is identical. It goes to its zero directly. You can check in GTune desktop this event.

Then you set both axes back to ranges above 40 degrees and the gimbal is perfectly positioned again. We have tried to change parameters inside GTune to see if we could modify how it acts, with no success.

Have any of you faced a similar behaviour or could give me any clue on how to abord this issue please?

Thank you in advance.

I’m having the same issue with the Gremsy T7. I can’t seem to find a solution for this. Hopefully, someone here can help us.

@Adrian_Gomez, my gimbal works at every angle now after flashing the recently released firmware 7.7.3


Yeah, it is a minor bug from the new 7.7.1 and 7.7.2 version. It sets the “Dead Zone” to 40 automatically in the Controls>Herelink window. Glad to hear they have fixed it!

And thank you from your reply!!


@Adrian_Gomez I see! Quick question, are you saying that the dead zone can be disabled in Controls>Herelink even though the Controls are actually set to SYNC for mavlink communication?

Have the new firmware for the MIo to fix some bugs with Mavlink control, You can try it via the link:

1 Like

Yes, I didn’t know either it could happen. I had to change control to Herelink, disable dead zone and change back to sync.

1 Like

Hello Adrian, I have a question, Did you solve the problem with the new firmware of the Mio?