Great Shark - EKF Error and Control Issues

Hi All,

I am pretty new to these discussion forums but hopefully I will get the info needed across the right way.

We purchased a RTF Great Shark 330 from Foxtech. We didn’t have them put in a telemetry radio or VTX equipment as we were concerned about FCC compliance issues. We have since installed the telemetry radio. All of the wiring and parameters were done by them. They test flew it and then sent it to us.

We took this out to conduct a hover test before moving on to flight tests. This is were we ran into issues.

Flight one was a short one in QHOVER. The Shark seemed to hold altitude and horizon just fine but drifted back at a steady clip. We chalked this up to wind (5-8mph) and landed it.

Flight two was in QLOITER. We wanted it to hold station where it was for us. Everything was good to go and we took off. This time the plane pitched forward and started going out away from us. When attempting to correct the controls were difficult to maintain and we were able to land it eventually with no damage.

As a RTF VTOL from Foxtech we did not expect this. Looking back we are thinking of the following things as potential issues.

  1. While we are competent quadcopter pilots our VTOL experience is minimum.
  2. The CG may have shifted. This may explain the wide variance in stick needed. One way needed full stick to make minor correctios and the opposite way needed minor stick to make major correction.
  3. There was a “DCM Yaw Inconsistent by 41 degrees” error that happened prior to one flight. The compass had been calibrated and after a reboot this went away.
  4. During motor throttle up and during flight there was an EKF error (with the compass). During ground tests where the throttle was used (without propellers) feedback noise was heard and the EKF for compass went to orange. Once the motors reached full throttle it went back to green.

We plan to send all of this to Foxtech but I know there are some savvy people here. Besides, I haven’t found anything on the Great Shark on here so I figured it would be nice to start a discussion for those interested.

Here is the link to the Bin and Parameters. I have also included the original parameters it was sent with.
https://1drv.ms/u/s!AlUpcOSA9ziViJsZFyozj_eTn1Ll5w?e=jlxNjb

Best, Adam

Hi Adam.

While I am no analyst(and wont pretend to help you there!), I do have a lot of experience with Foxtech off-the-shelf products that can possibly help.

While Foxtech do source and sell some affordable stuff, there is often a lot of shortcuts that they take when considering the equipment layout. We own a good few of their VTOLs / multirotors and have had to modify every one of them. We have had to also check and verify all the wiring too as we have noticed a number of quality issues with soldering, bend points, fiction areas and of course loose screws / bolts.

For all our issues with the yaw errors, these have simply been solved by extending wiring to the compass / GPS and moving it as far away from any interference. While not in your case, Li-Ion batteries seem to generate a lot of issues we have noted and by placing the GPS as far away from this, ESC and other high current wiring, helps tremendously.

Another point about Foxtech products we have noted is that they all seem to have identical parameters. Thus, I doubt that any of them are actually tuned or calibrated despite the “test flight” hover. While this is perhaps a good starting point, we always have to spend a few days dialing the aircraft in to suit our needs. We had a few Baby Sharks arrive all with identical params.

All in all, their buying power keeps the pricing down which is great. But these aircraft need some work on to be stable and safe enough for commercial work. They offer a great starting point but I would not consider them RTF as you need to check a number of key points first and make the modifications as necessary.

Why don’t you try to ask Foxtech for help, they should provide some on a 10k USD product.

Yep, we are in the process of doing this. I figured we would cover our bases and it’s always nice to add to a communities knowledge base when we can.

Thanks for your great response. We are trying to reach out to a college as well that has some of these. We have had issues with bolts and such as well.

The compasses on this are external but one of them is above the battery bay. It looks like it is using 3 total, two external on the Here3 modules and one internal. We also are at a very high latitude here, 70 degrees. This plays havoc sometimes on magnetic compasses. We also have limited satellites up here (Although we had 18 on the day of the flight). We are looking into maybe disabling them and running off GPS only.

We received back a response from Foxtech that didn’t provide much usable info. Basically make sure we have satellites, calibrate your compass, and that the EKF error would be there during the transition until we switched to forward flight.

They are cheap and that is one of the big reasons we did go with them. What we needed our drone to do was very cost prohibitive with other airframes and manufactures.

Best,
Adam

Hi Adam,
This issue looks normal as QHOVER mode only uses the BARO for Altitude Hold.

Your pitch and roll control (see below) in QLOITER mode seemed fine. This would suggest that your PID tuning is reasonable. The quad motor power level also seemed fine and you had a constant 19 satellites for a good 3D position lock.

It did look rather windy out as, at times, there was a 6m/s difference between the ground speed and the wind. You have a large plane so it will get pushed by the wind unless the nose is pointed directly towards it.

I see that you have multiple compasses enabled. I am not a fan of this configuration. You could try leaving only one external compass enabled (COMPASS_USE2=0) to see if this helps. The EKF yaw reset on throttle up is normal but you did switch compasses during the QLOITER.

Looking at the QLOITER movement and the pilot stick movement (RCin), it is difficult to tell if it was affected by wind or pilot or something else. You could try re-calibrating the 1-axis level position in Mission Planner to make sure that there isn’t a forward bias. You could also recalibrate the compass(es) at the sight you were flying.

Good luck!

Hi Greg,

Thanks a ton for this. I have always enjoyed your responses in other threads and this is no change. We are deactivation all but one of the forward compasses.We have also started to talk to Kansas State University as they have 5 of the Great Sharks for their flight programs.

Best,
Adam

Hello friend. can you share your log again ? link is dead.
I’m having a near problem.

Hello Chris,

Here is a new link to the files. Please let me know if it works.

Best,
Adam

1 Like

We have another VTOL, resolved the EKF error.

Hi All,

Just wanted to follow back up on this. We were able to resolve this issue eventually. Of the three compasses we have on board two are external and the forward most one was set as the primary. This compass was inside a Here3 GPS module. It was also placed above a wiring hub that fed power to and from the vtol and pusher motors.

This caused a mag error and a 110 degree yaw swing. After that it was pilot input trying to counter the movements of the UAV while it was going through its yaw reset. Adding to this the Great Shark has a very sensitive yaw.

We disabled the forward compass and it now works. It flys beautifully. Thanks for all the input.

Best,
Adam

Hello t.
We bought the big shark 3.2 m from foxtech.
Sent without any installation on it.
When we did not have experience in flight and installation, we suffered 3 massacres.
Can you help me with the installation?

Howdy. I would be happy to try to help but I will need more information as to the actual problems you are having?

What do you mean by sent without installation?

Best,
Adam

After purchasing the device equipment (engine pixhawk) was sent.

When I talked to foxtech they said they only sell hardware and they can’t help me with the flight.

I tried to install it with my own means, but there are problems with the pid settings.

Best,
Dasdanidris