Servers by jDrones

GPS1 failing at configuration check. SBAS settings?

hereplus
arducopter

(Muqing Cao) #1

Hi,

I am running HERE+ RTK GNSS with arducopter firmware 3.5, but when I try to arm the motor in loiter mode, it shows the error in the photo below:

But when i try to arm in stabile and then switch to loiter, it is fine. Really appreciate any suggestion on the issue. I have also uploaded the parameter of my copter:

matrix param20171011.txt (13.5 KB)


(WickedShell) #2

Set GPS_SBAS_MODE 2. GPS_SBAS_MODE 0 requires fetching the SBAS settings, which is not possible with an M8P.


(Justin) #3

I have the same setup with the same issue, when i change sbas to 2, it says gps2 failing comfiguration check.


(WickedShell) #4

@Rcmaniac Can you post a tlog or dataflash file? (At least the rest of the screen, it will send you another text message that says what part is failing)


(Justin) #5

Its weird cause why is it looking for gps 2 if gp2 and gps3 are dissabled. Maybe thats the problem, should i re check those boxs to renable them, i doubt thats the issue though.


(WickedShell) #6

Do you have the params? Off the top of my head if GPS_TYPE2 is not 0 then we will require a second GPS to be configured before allowing it to boot. If you have that set to 0, then if you can send me your full param set (or a log file) I will try and replicate it here.


(Justin) #7

params.param (13.5 KB)

here are the params. Thanks for all your help!


(WickedShell) #8

GPS 2 is enabled, set GPS_TYPE2 to 0 to mark that we aren’t trying to find a second GPS instance. If the instance is supposed to be present we require it before allowing arming.


(Justin) #9

okay so i set GPS_TYPE2 to 0 and now im getting a new error when i try to arm in position hold mode.


(WickedShell) #10

If you don’t have a second GPS then you can’t do GPS blending. Setting GPS_TYPE2 to 0 disabled the second GPS instance. I’m assuming you don’t actually have a second GPS on the system?

Anyways to disable blending and let you through the arming checks GPS_AUTO_SWITCH to 0 (disables any switching) or 1 (switch to the better GPS instance if you plugged a second GPS in) would work.


(Justin) #11

Well that fixed it, thanks for all your help!