GPS_YAW cannot be used

Hello, everybody.

I configured GPS_YAW on my rover, but it failed all the time. Can you guys help me?
At present, the following problems have been found:

  1. The default rover’s current course is 0 degrees after startup, so the correct course cannot be displayed.
  2. The device cannot be unlocked in Auto mode, and “GPS[2]yaw not available” is displayed.However, a linear change in heading (although the heading is incorrect) can be seen by turning the vehicle.

The ground station status is shown in Figure 1, and the status of the two GPS hardware is shown in Figure 2.

Figure 1

Figure 2

In Figure 2, GPS1 is at the top and GPS2 is at the bottom. The orange indicator indicates that the position has been obtained, the red indicator indicates that the power is switched on, and the green indicator indicates that the RTK signal has been received.

The controller I use is CUAV V5+, the GPS module is two CUAV RTK-9P, the firmware I use is ArduRover V4.2.0-Beta2, but after testing, version 4.1 also has this problem
UART1 of Gps1 connects to UART4 of flight control, UART1 of Gps2 connects to UART7 of flight control, and UART2 of Gps1 connects to UART2 of Gps2.

The configuration file is as follows:

The log file is as follows:

Your configuration appears correct, but the log file indicates an extremely erratic/inconsistent number of satellites in view and very low precision estimate.

The green light on GPS2 is also a likely indicator of correct configuration, but the lack of RTK fix type (as displayed in your screenshot and confirmed by the log) is a result of the weak position estimates.

Be sure the antennas are in clear view of the sky and oriented correctly with the correct distance between them (0.38m, according to your GPS_POS2_Y parameter).

Just FYI-This is likely from from the Z-axis gyro. Normal.

Thank you @Yuri_Rage

Today, I found an open field for testing. Under the condition of good satellite signal quality, GPS_YAW became available, which really has a lot to do with the quality of satellite signal.

1 Like

Thank you @dkemxr

I tried to ignore the heading display, which really does not affect actual use.

Hello, I met the same problem. Is the problem caused by the baseline distance less than 30cm?


I’m not sure that the 30cm distance is a hard requirement but there’s certainly no guarantee it will work if they’re closer than that. You’ve followed the instructions on the wiki? If you have and you’re testing in an area with good GPS reception and it’s still not working please post an onboard log.

Txs for using AP!

Thanks! I solved this problem followed

This is the test result

1 Like


Great news. I’ve created an issue to update our wiki instructions.

1 Like