GPS waiting for home


I have some weird issues with ublox m8q and m8n GPS modules.
First of all I have done all possible calibrations beforehand and get different results each day. For example, here is a log from yesterday when everything was ok. I didnt fly but got a good home location and things were all in the green. Todays logs without changing anything I am unable to get a home location, altough I get 8-10 sats and 3dlock.

Logs can be found here - 21.12 is a “good one” and everything else seems bad.

I looked at the last log - number of sats is very low, HDOP is bad (>1.0)
Check the voltage supply to the GPS units, and try disconnecting other devices like telemetry radios to see if they are causing interference.
Is it because of environment? Under trees or near buildings?
You will only need to redo calibrations if you move the compasses or flight controller.

Check and use all these below

Try GPS_GNSS_MODE,5 or 65 but dont select more than 2 constellations at once.
Make GPS_GNSS_MODE2 the same too.
I would put this back to default, otherwise you will get poor positioning and home position.
or even up to 5000 to ensure CAN devices have booted before the flight controller.

I would set

Any special reason for
otherwise disable it

Looking at the good log
There’s just enough difference in GPS quality to allow a usable fix

Is the GPS unit separated from everything else enough?

You can see on the map the position is still not great for the first half of the log

Hey. Just check that the first one was not indoors. Might have been. What parameter are u looking to get a gps quality?

The drone is a rather tightly packed one. Gimbal controller is nearby, ~1cm, 1w radio antennas are ~10cm away. Will try to add a gps groundplane tomorrow. All of the wires are twisted and emi shielding tape is applied.

These are self explanatory
This is the update rate from the GPS to the flight controller
It should be a straight line along 200ms
Yours is good, but it’s something to check whenever there’s GPS issues.

The big problem with most GPS units is being overwhelmed by the number of constellations and satellites. You dont seem to have that problem, which makes me think the issue will be interference.
It’s still better to limit the constellations to something that
a) works well in your area
b) wont overwhelm the GPS unit and slow the update rate

The issue that I get most of the times is that the same spot on a different day gives me different results. The GPS that I use is the holybro micro m8n. On a good day I take it out of the case, it comes up in about a minute or 2 and i get a home location and 24 hours later I could not replicate it. The GPS starts like it would have no idea where on earth it is located, gps lock takes time and the visible sats are low.

What im trying to achieve is a consistant boot every time. The GPS module has a backup battery, and it is around 2.8v, so it should be able to remember the gps time and where the constellations are, but it is not.

What happens if the GPA.Delta is lower than 200ms?

If the Delta is fluctuating a lot it means the GPS unit cant process all the satellite data fast enough to forward it on. So far you dont have enough satellites :slight_smile:
When the rate varies a lot, or is generally low, the GPS position is not matching well to the IMU calculated positions and leads to poor position accuracy and “GPS Glitch” messages. It generally makes life hard for the EKF to keep track of where the copter is, and whether GPS or IMU’s are telling the truth.

For example the update rate of a M8P-2 (Here3) with 3 constellations is only 8Hz (125ms)

The other thing not on your side is the small size of the antenna on the GPS unit you are using. It would need to be mounted higher and further away from other electronics to be effective.
A ground plane will help.

so it seems there might be a interference coming somewhere from the drone. Will try a ground plane tomorrow and/or see if i could get a bigger gps module.

Just unplug all accessories except the GPS unit and see how that works - just as a test.
Then reconnect each accessory in turn to find out which is causing interference, if any.
And do all the other settings I mentioned.

I tried that and it seemd that the gimbal controller was the culprit, but the next day without doing any changes, i was unable to get a good home location.

I did all of the changes. The gps after 10 hours acted like a cold start unit. Had to wait about 10 min to see any sats.

Hello @xfacta here´s todays flightlog.

Yes after some hours the GPS does a cold start, that’s normal. I think maximum warm start time is 4 hours.

I looked at the latest log there. You can see even in flight at some altitude the number of sats goes down and HDOP goes up for no apparent reason - that’s a very poor GPS signal for some reason.
And on the ground between flights you were getting the same thing - shown as GPS Glitches in messages. That’s almost to be expected while on the ground if you are already having some GPS issues.

So maybe there’s still too much interference from something, or the module is faulty. Are you getting a good solid 5 volts DC at the GPS unit?

How is the GPS performance and update rate with GPS_GNSS_MODE,5 ?

I might be getting 4.5v on the dc line. I will try to change the gps mode to 5. I will try a separate bec, also will try a zed f9p with an active antenna.

Do you know that does ublox assist now anonomys help in any way?

I used f9p and its spectral analyser to produce these two images

@xfacta it seems that the culprit was a ground loop on some of the serial cables.

Both of those devices were powered from the same place that the cube was powered from and in addition, sinve i use 2 pdbs for front and rear arms, the signal grounds also made a groundloop.

After removing the groundloops i saw that the initial lock was faster and it did not move around on the screen